aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-07-26 13:32:02 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-07-26 13:32:02 +0000
commitdb61dbe67ce470063fb824973947f449d4994e9e (patch)
tree682063f7f35fea026ac6105250c9d884a9207ba2
parent6d2ba97481de5894a796a384a85126053bfcf25f (diff)
downloadupstream-db61dbe67ce470063fb824973947f449d4994e9e.tar.gz
upstream-db61dbe67ce470063fb824973947f449d4994e9e.tar.bz2
upstream-db61dbe67ce470063fb824973947f449d4994e9e.zip
allow mkfwimage to fail during atheros builds.
sometimes images get too big for devices that use this image format, but this must not break the normal image build for other atheros devices git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11934 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/atheros/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/atheros/image/Makefile b/target/linux/atheros/image/Makefile
index 17b18deeed..343e2dedf7 100644
--- a/target/linux/atheros/image/Makefile
+++ b/target/linux/atheros/image/Makefile
@@ -23,11 +23,11 @@ define Image/Build
$(call Image/Build/$(1))
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
- $(STAGING_DIR_HOST)/bin/mkfwimage -k $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma \
+ -$(STAGING_DIR_HOST)/bin/mkfwimage -k $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma \
-r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
-v XS2.ar2316.OpenWRT \
-o $(BIN_DIR)/openwrt-$(BOARD)-ubnt2-$(1).bin
- $(STAGING_DIR_HOST)/bin/mkfwimage -k $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma \
+ -$(STAGING_DIR_HOST)/bin/mkfwimage -k $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma \
-r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
-v XS5.ar2313.OpenWRT \
-o $(BIN_DIR)/openwrt-$(BOARD)-ubnt5-$(1).bin \