aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-04-02 10:43:04 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-04-02 10:43:04 +0000
commitd8372fba558ccaf85624a6ab37d88cf31de6fe23 (patch)
treee4638dda8706993761836244b977d1463e25fd05
parentf5618816f12cf41dd6ab424ea756d2da657ba1ec (diff)
downloadupstream-d8372fba558ccaf85624a6ab37d88cf31de6fe23.tar.gz
upstream-d8372fba558ccaf85624a6ab37d88cf31de6fe23.tar.bz2
upstream-d8372fba558ccaf85624a6ab37d88cf31de6fe23.zip
fix build depends for wlc
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@512 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/openwrt/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/openwrt/Makefile b/package/openwrt/Makefile
index 4c129fd4ce..1580c13a91 100644
--- a/package/openwrt/Makefile
+++ b/package/openwrt/Makefile
@@ -10,10 +10,10 @@ PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
SHARED_INCLUDE:=${shell pwd}/include
-libshared-compile libnvram-compile wlc-compile:
+libshared-compile libnvram-compile:
@$(MAKE) -C $(patsubst %-compile,%,$@) compile
-libshared-install libnvram-install wlc-install:
+libshared-install libnvram-install: libshared-compile libnvram-compile
@$(MAKE) -C $(patsubst %-install,%,$@) install
libshared-clean libnvram-clean wlc-clean:
@@ -27,7 +27,7 @@ $(PKG_IPK_DIR)/sbin/jffs2root: jffs2root.c
mkdir -p $(PKG_IPK_DIR)/sbin
$(TARGET_CC) -o $@ $<
-$(PKG_IPK_DIR)/usr/sbin/wlc: wlc.c libshared-compile
+$(PKG_IPK_DIR)/usr/sbin/wlc: wlc.c libshared-install
mkdir -p $(PKG_IPK_DIR)/usr/sbin
$(TARGET_CC) -o $@ $< -lshared -L./libshared -I$(SHARED_INCLUDE)