aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-11-16 04:10:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-11-16 04:10:01 +0000
commitcff9b75e6abd2aa97f4520f3c1ee828949076ff8 (patch)
treeef278b566a09aa9f3822a3712105464c77982baf
parentd437171f600f80220030a3b2ec9dfe4e89d1d048 (diff)
downloadupstream-cff9b75e6abd2aa97f4520f3c1ee828949076ff8.tar.gz
upstream-cff9b75e6abd2aa97f4520f3c1ee828949076ff8.tar.bz2
upstream-cff9b75e6abd2aa97f4520f3c1ee828949076ff8.zip
prefer http downloads over svn/git checkouts, remove git dependency
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9567 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/download.mk4
-rw-r--r--include/prereq-build.mk8
2 files changed, 1 insertions, 11 deletions
diff --git a/include/download.mk b/include/download.mk
index 3c7cb7e77b..23f2996ed1 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -39,9 +39,7 @@ define DownloadMethod/default
endef
define wrap_mirror
- @$(if $(CONFIG_LOCALMIRROR),$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "x" || ) \
- ( $(1) ) \
- $(if $(CONFIG_LOCALMIRROR),, || $(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "x")
+ @$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "x" || ( $(1) )
endef
define DownloadMethod/svn
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 9b77a1baf7..1e448d393f 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -119,14 +119,6 @@ $(eval $(call Require,gnutar, \
Please install GNU tar. \
))
-define Require/git
- which git-clone
-endef
-
-$(eval $(call Require,git, \
- Please install git. \
-))
-
$(eval $(call RequireCommand,svn, \
Please install the subversion client. \
))