aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-08-19 15:12:54 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-08-19 15:12:54 +0000
commitcdb9ae12f93ef2db330ee4a83b59354f60a4c99a (patch)
treeab13a5c1dd3d465788b7b411ed6d179464aad6d8
parentdd83d5b728b4d89b7760e325a772c3d77cfd7e41 (diff)
downloadupstream-cdb9ae12f93ef2db330ee4a83b59354f60a4c99a.tar.gz
upstream-cdb9ae12f93ef2db330ee4a83b59354f60a4c99a.tar.bz2
upstream-cdb9ae12f93ef2db330ee4a83b59354f60a4c99a.zip
when regenerating an ipkg package, make sure the entire ipkg build dir is cleaned as well to prevent stale files from making it into the package after configuration changes
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17313 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/package-ipkg.mk6
1 files changed, 2 insertions, 4 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 72d6d596b7..5d5c826842 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -57,8 +57,9 @@ ifeq ($(DUMP),)
$(eval $(call BuildIPKGVariable,$(1),postinst))
$(eval $(call BuildIPKGVariable,$(1),prerm))
$(eval $(call BuildIPKGVariable,$(1),postrm))
- $$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.version-$(1)_$(VERSION)_$(PKGARCH)
+ $$(IDIR_$(1))/CONTROL/control: $(STAMP_BUILT)
@rm -f $(PACKAGE_DIR)/$(1)_*
+ rm -rf $$(IDIR_$(1))
mkdir -p $$(IDIR_$(1))/CONTROL
echo "Package: $(1)" > $$(IDIR_$(1))/CONTROL/control
echo "Version: $(VERSION)" >> $$(IDIR_$(1))/CONTROL/control
@@ -107,9 +108,6 @@ ifeq ($(DUMP),)
clean: $(1)-clean
- $(PKG_BUILD_DIR)/.version-$(1)_$(VERSION)_$(PKGARCH): $(STAMP_PREPARED)
- -@rm -f $(PKG_BUILD_DIR)/.version-$(1)_* 2>/dev/null
- @touch $$@
endef
$(STAGING_DIR)/etc/ipkg.conf: