aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-05-04 16:13:46 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-05-04 16:13:46 +0000
commitc8e41e8aa887902bf54d02ca6637df26c244efaa (patch)
tree32e3e862b9eea5494cddce6a00806eebd6f6c103
parent403d960fee780c6716a2eb9e369f942cdf9351ce (diff)
downloadupstream-c8e41e8aa887902bf54d02ca6637df26c244efaa.tar.gz
upstream-c8e41e8aa887902bf54d02ca6637df26c244efaa.tar.bz2
upstream-c8e41e8aa887902bf54d02ca6637df26c244efaa.zip
fix more issues with libnl-tiny and eglibc
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15592 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/crda/Makefile1
-rw-r--r--package/hostapd/Makefile3
-rw-r--r--package/iw/Makefile3
3 files changed, 5 insertions, 2 deletions
diff --git a/package/crda/Makefile b/package/crda/Makefile
index 6585117052..e53db3dfdc 100644
--- a/package/crda/Makefile
+++ b/package/crda/Makefile
@@ -51,6 +51,7 @@ endef
TARGET_CPPFLAGS := \
-I$(STAGING_DIR)/usr/include/libnl-tiny \
+ -D_GNU_SOURCE \
$(TARGET_CPPFLAGS)
MAKE_FLAGS += \
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index bd873b9b2f..6d0b18bcd9 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -98,7 +98,8 @@ TARGET_CPPFLAGS := \
$(TARGET_CPPFLAGS) \
-I$(STAGING_DIR)/usr/include/madwifi \
-I$(STAGING_DIR)/usr/include/mac80211 \
- -DCONFIG_LIBNL20
+ -DCONFIG_LIBNL20 \
+ -D_GNU_SOURCE
define Build/CompileTarget
CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
diff --git a/package/iw/Makefile b/package/iw/Makefile
index 9187b55c85..fb10f10f2f 100644
--- a/package/iw/Makefile
+++ b/package/iw/Makefile
@@ -37,7 +37,8 @@ TARGET_CPPFLAGS:= \
-I$(STAGING_DIR)/usr/include/libnl-tiny \
-I$(STAGING_DIR)/usr/include/mac80211 \
$(TARGET_CPPFLAGS) \
- -DCONFIG_LIBNL20
+ -DCONFIG_LIBNL20 \
+ -D_GNU_SOURCE
MAKE_FLAGS += \
CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \