aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-10-30 21:47:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-10-30 21:47:08 +0000
commitc6ab7c0f22803aba103685d31bb2a48313ac747a (patch)
tree1de6e67313e2083841bcd8b06cffe12c5ae16cd3
parent6fa3c3e899a34962ab9ac50181b1bac8c940cfc6 (diff)
downloadupstream-c6ab7c0f22803aba103685d31bb2a48313ac747a.tar.gz
upstream-c6ab7c0f22803aba103685d31bb2a48313ac747a.tar.bz2
upstream-c6ab7c0f22803aba103685d31bb2a48313ac747a.zip
AA: tools/cmake: update to latest version from trunk to fix build errors
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@38619 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--tools/cmake/Makefile6
-rw-r--r--tools/cmake/patches/100-disable_qt_tests.patch32
2 files changed, 35 insertions, 3 deletions
diff --git a/tools/cmake/Makefile b/tools/cmake/Makefile
index 2fca3a8e59..efcca4391b 100644
--- a/tools/cmake/Makefile
+++ b/tools/cmake/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -7,11 +7,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=cmake
-PKG_VERSION:=2.8.9
+PKG_VERSION:=2.8.12
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.cmake.org/files/v2.8/
-PKG_MD5SUM:=801f4c87f8b604f727df5bf1f05a59e7
+PKG_MD5SUM:=105bc6d21cc2e9b6aff901e43c53afea
HOST_BUILD_PARALLEL:=1
HOST_CONFIGURE_PARALLEL:=1
diff --git a/tools/cmake/patches/100-disable_qt_tests.patch b/tools/cmake/patches/100-disable_qt_tests.patch
new file mode 100644
index 0000000000..3d44dac53f
--- /dev/null
+++ b/tools/cmake/patches/100-disable_qt_tests.patch
@@ -0,0 +1,32 @@
+--- a/Tests/RunCMake/CMakeLists.txt
++++ b/Tests/RunCMake/CMakeLists.txt
+@@ -101,16 +101,6 @@
+ add_RunCMake_test(TargetPolicies)
+ add_RunCMake_test(alias_targets)
+
+-find_package(Qt4 QUIET)
+-find_package(Qt5Core QUIET)
+-if (QT4_FOUND AND Qt5Core_FOUND AND NOT Qt5Core_VERSION VERSION_LESS 5.1.0)
+- add_RunCMake_test(IncompatibleQt)
+-endif()
+-if (QT4_FOUND)
+- set(ObsoleteQtMacros_ARGS -DQT_QMAKE_EXECUTABLE:FILEPATH=${QT_QMAKE_EXECUTABLE})
+- add_RunCMake_test(ObsoleteQtMacros)
+-endif()
+-
+ if("${CMAKE_TEST_GENERATOR}" MATCHES "Visual Studio [^6]")
+ add_RunCMake_test(include_external_msproject)
+ add_RunCMake_test(SolutionGlobalSections)
+--- a/Tests/CMakeLists.txt
++++ b/Tests/CMakeLists.txt
+@@ -262,10 +262,6 @@
+
+ list(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})
+
+- if(NOT QT4_FOUND)
+- find_package(Qt4)
+- endif()
+-
+ if(QT4_FOUND)
+ # test whether the Qt4 which has been found works, on some machines
+ # which run nightly builds there were errors like "wrong file format"