aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-03-26 05:04:13 +0000
committerNicolas Thill <nico@openwrt.org>2007-03-26 05:04:13 +0000
commitc3eb6c30f6fc6491fe196c3cffd3797a9ea46a19 (patch)
tree46eb35ceb610dc6015cbca44c70f64442f13dc6a
parentb56546a0a81f3cc97a5dcf288b92c624cf742113 (diff)
downloadupstream-c3eb6c30f6fc6491fe196c3cffd3797a9ea46a19.tar.gz
upstream-c3eb6c30f6fc6491fe196c3cffd3797a9ea46a19.tar.bz2
upstream-c3eb6c30f6fc6491fe196c3cffd3797a9ea46a19.zip
enable dso support back in openssl, needed to use shared zlib compression, and should fix the "error:2507006C:lib(37):func(112):reason(108)" errors.
closes: #1182 git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6706 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/openssl/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index 9a9661e783..b097c1b37f 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openssl
PKG_VERSION:=0.9.8d
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.openssl.org/source/ \
@@ -60,7 +60,7 @@ endef
OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc2 no-rc5 no-sha0 no-smime \
no-rmd160 no-aes192 no-ripemd no-camellia no-ans1 no-krb5
-OPENSSL_OPTIONS:= shared no-dso no-ec no-err no-fips no-hw no-threads zlib-dynamic \
+OPENSSL_OPTIONS:= shared no-ec no-err no-fips no-hw no-threads zlib-dynamic \
no-engines no-sse2 no-perlasm