aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-11-04 22:43:05 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-11-04 22:43:05 +0000
commitc3b4b1b54f3da42f13508dca250cd37bcf750df3 (patch)
tree57e92999a2759dbb335fd2f529a8843ed6843535
parentcb9726bc5f2bc17488db70016b188cdc7c0ee837 (diff)
downloadupstream-c3b4b1b54f3da42f13508dca250cd37bcf750df3.tar.gz
upstream-c3b4b1b54f3da42f13508dca250cd37bcf750df3.tar.bz2
upstream-c3b4b1b54f3da42f13508dca250cd37bcf750df3.zip
[rdc] make rdc321-wdt become a package, saves some space in the kernel
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18298 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/kernel/modules/other.mk15
-rw-r--r--target/linux/rdc/config-2.6.281
2 files changed, 15 insertions, 1 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 28ba41469d..bf26beffa9 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -419,6 +419,21 @@ endef
$(eval $(call KernelPackage,softdog))
+define KernelPackage/rdc321x-wdt
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=RDC321x watchdog
+ DEPENDS:=@TARGET_rdc
+ KCONFIG:=CONFIG_RDC321X_WDT
+ FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/rdc321x_wdt.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,50,rdc321_wdt)
+endef
+
+define KernelPackage/rdc321x-wdt/description
+ RDC-321x watchdog driver
+endef
+
+$(eval $(call KernelPackage,rdc321x-wdt))
+
define KernelPackage/leds-gpio
SUBMENU:=$(OTHER_MENU)
diff --git a/target/linux/rdc/config-2.6.28 b/target/linux/rdc/config-2.6.28
index 7fec13148f..a8561b7871 100644
--- a/target/linux/rdc/config-2.6.28
+++ b/target/linux/rdc/config-2.6.28
@@ -217,7 +217,6 @@ CONFIG_PHYSICAL_START=0x100000
# CONFIG_PROCESSOR_SELECT is not set
# CONFIG_PROVIDE_OHCI1394_DMA_INIT is not set
# CONFIG_R6040 is not set
-CONFIG_RDC321X_WDT=y
# CONFIG_RD_BZIP2 is not set
CONFIG_RD_GZIP=y
# CONFIG_RD_LZMA is not set