aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-07-24 21:39:27 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-07-24 21:39:27 +0000
commitad34f6c768122a9c2995545765d574146b7e4fc2 (patch)
treecec2ad78db9812c463b95e334eb7e1d99984aca0
parent56d7649922e5264dfb4ccb216ff67cfe3c7ffd3e (diff)
downloadupstream-ad34f6c768122a9c2995545765d574146b7e4fc2.tar.gz
upstream-ad34f6c768122a9c2995545765d574146b7e4fc2.tar.bz2
upstream-ad34f6c768122a9c2995545765d574146b7e4fc2.zip
[package] e2fsprogs: parallel build fix
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22382 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/e2fsprogs/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/package/e2fsprogs/Makefile b/package/e2fsprogs/Makefile
index 847d40d2b7..3a6a966937 100644
--- a/package/e2fsprogs/Makefile
+++ b/package/e2fsprogs/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
# Copyright 2010 Vertical Communications
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -15,6 +15,8 @@ PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/e2fsprogs
+PKG_INSTALL:=1
+
include $(INCLUDE_DIR)/package.mk
define Package/e2fsprogs/Default
@@ -64,7 +66,7 @@ define Package/libblkid
$(call Package/e2fsprogs/Default)
SECTION:=libs
CATEGORY:=Libraries
- TITLE:=block device id library
+ TITLE:=Block device id library
endef
define Package/libblkid/description
@@ -132,7 +134,7 @@ define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
BUILDCC="$(HOSTCC)" \
DESTDIR="$(PKG_INSTALL_DIR)" \
- all install
+ all
endef
define Build/InstallDev