aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-10-02 16:47:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-10-02 16:47:17 +0000
commita3bb44cb3df06235e2c33e2b5023f4a0f19d5985 (patch)
treee965325d4edb55494d633fced8f91d6ac27b5650
parent150c43b4a227129e8ab48ab731614d84feed802e (diff)
downloadupstream-a3bb44cb3df06235e2c33e2b5023f4a0f19d5985.tar.gz
upstream-a3bb44cb3df06235e2c33e2b5023f4a0f19d5985.tar.bz2
upstream-a3bb44cb3df06235e2c33e2b5023f4a0f19d5985.zip
bump wificonf version number, remove wl0_wet variable support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2023 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/wificonf/Makefile2
-rw-r--r--package/wificonf/wificonf.c2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/wificonf/Makefile b/package/wificonf/Makefile
index 4dd452955f..f6608331b1 100644
--- a/package/wificonf/Makefile
+++ b/package/wificonf/Makefile
@@ -3,7 +3,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=wificonf
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_BUILD_DIR:=$(BUILD_DIR)/wificonf
diff --git a/package/wificonf/wificonf.c b/package/wificonf/wificonf.c
index 0d652ee159..6bb26b1345 100644
--- a/package/wificonf/wificonf.c
+++ b/package/wificonf/wificonf.c
@@ -430,7 +430,7 @@ void set_wext_mode(skfd, ifname)
/* Set operation mode */
ap = !nvram_match(wl_var("mode"), "sta") && !nvram_match(wl_var("mode"), "wet");
infra = !nvram_disabled(wl_var("infra"));
- wet = nvram_enabled(wl_var("wet")) || !nvram_match(wl_var("mode"), "wet");
+ wet = nvram_match(wl_var("mode"), "wet");
wrq.u.mode = (!infra ? IW_MODE_ADHOC : (ap ? IW_MODE_MASTER : (wet ? IW_MODE_REPEAT : IW_MODE_INFRA)));
IW_SET_EXT_ERR(skfd, ifname, SIOCSIWMODE, &wrq, "Set Mode");