aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-04-14 13:24:30 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-04-14 13:24:30 +0000
commita2f9064438b2193dd4b349e39fb2b2ed14c0de25 (patch)
tree45650e3b54380baf5a44e0639b4825197ab96f0c
parent050ff23cdd6708459636193a6e47dfe216411ea6 (diff)
downloadupstream-a2f9064438b2193dd4b349e39fb2b2ed14c0de25.tar.gz
upstream-a2f9064438b2193dd4b349e39fb2b2ed14c0de25.tar.bz2
upstream-a2f9064438b2193dd4b349e39fb2b2ed14c0de25.zip
do target dependent optimizations
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10834 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/madwifi/Makefile4
-rw-r--r--toolchain/Config.in2
2 files changed, 3 insertions, 3 deletions
diff --git a/package/madwifi/Makefile b/package/madwifi/Makefile
index 918424db2d..f2fdac7b9d 100644
--- a/package/madwifi/Makefile
+++ b/package/madwifi/Makefile
@@ -39,10 +39,10 @@ endif
ifeq ($(ARCH),i686)
HAL_TARGET:=i386-elf
endif
-ifeq ($(ARCH),armeb)
+ifeq ($(BOARD),ixp4xx)
HAL_TARGET:=xscale-be-elf
endif
-ifeq ($(ARCH),arm)
+ifeq ($(BOARD),iop32x)
HAL_TARGET:=xscale-le-elf
endif
ifeq ($(ARCH),powerpc)
diff --git a/toolchain/Config.in b/toolchain/Config.in
index c4f6e14f57..1d7f1ab07a 100644
--- a/toolchain/Config.in
+++ b/toolchain/Config.in
@@ -84,7 +84,7 @@ config TARGET_OPTIMIZATION
default "-O2 -pipe -march=i486 -funit-at-a-time" if TARGET_x86
default "-Os -pipe -march=i486 -funit-at-a-time" if TARGET_rdc
default "-Os -pipe -mips32 -mtune=mips32 -funit-at-a-time" if mipsel || mips
- default "-Os -pipe -march=armv5te -mtune=xscale -funit-at-a-time" if armeb || arm
+ default "-Os -pipe -march=armv5te -mtune=xscale -funit-at-a-time" if TARGET_ixp4xx || TARGET_iop32x
default "-Os -pipe -funit-at-a-time"
help
Optimizations to use when building for the target host.