aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-10-09 03:19:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-10-09 03:19:07 +0000
commita1d7a399e41e4848f3f31db96d9e885785c21cd3 (patch)
tree54e07839c6db3e2fa87788b2bc6e46e5a39ba501
parent68ceff0c36e5494cb42ccf1b7c3cd9466cc6031e (diff)
downloadupstream-a1d7a399e41e4848f3f31db96d9e885785c21cd3.tar.gz
upstream-a1d7a399e41e4848f3f31db96d9e885785c21cd3.tar.bz2
upstream-a1d7a399e41e4848f3f31db96d9e885785c21cd3.zip
move grub to package/
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9212 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/grub/Makefile (renamed from target/linux/x86/image/grub/Makefile)11
-rw-r--r--package/grub/menu.lst (renamed from target/linux/x86/image/grub/menu.lst)0
-rw-r--r--package/grub/patches/010-fixes-1.patch (renamed from target/linux/x86/image/grub/patches/010-fixes-1.patch)0
-rw-r--r--target/linux/x86/image/Config.in1
-rw-r--r--target/linux/x86/image/Makefile8
5 files changed, 11 insertions, 9 deletions
diff --git a/target/linux/x86/image/grub/Makefile b/package/grub/Makefile
index dae74e9dc2..9fc98173f5 100644
--- a/target/linux/x86/image/grub/Makefile
+++ b/package/grub/Makefile
@@ -19,9 +19,18 @@ PKG_MD5SUM:=cd3f3eb54446be6003156158d51f4884
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/grub-$(PKG_VERSION)
+PKG_TARGETS:=bin
include $(INCLUDE_DIR)/package.mk
+define Package/grub
+ SECTION:=boot
+ DEPENDS:=@TARGET_x86
+ CATEGORY:=Boot Loaders
+ TITLE:=GRand Unified Bootloader
+ URL:=http://www.gnu.org/software/grub/
+endef
+
ifeq ($(HOST_ARCH),x86_64)
CONFIGURE_FLAGS:= \
--target=$(GNU_TARGET_NAME) \
@@ -70,4 +79,4 @@ define Build/InstallDev
mv $(STAGING_DIR_HOST)/usr/sbin/grub $(STAGING_DIR_HOST)/bin
endef
-$(eval $(call Build/DefaultTargets))
+$(eval $(call BuildPackage,grub))
diff --git a/target/linux/x86/image/grub/menu.lst b/package/grub/menu.lst
index cb306cc443..cb306cc443 100644
--- a/target/linux/x86/image/grub/menu.lst
+++ b/package/grub/menu.lst
diff --git a/target/linux/x86/image/grub/patches/010-fixes-1.patch b/package/grub/patches/010-fixes-1.patch
index 6628b73822..6628b73822 100644
--- a/target/linux/x86/image/grub/patches/010-fixes-1.patch
+++ b/package/grub/patches/010-fixes-1.patch
diff --git a/target/linux/x86/image/Config.in b/target/linux/x86/image/Config.in
index 4a36f63128..17deccfa72 100644
--- a/target/linux/x86/image/Config.in
+++ b/target/linux/x86/image/Config.in
@@ -2,6 +2,7 @@ config X86_GRUB_IMAGES
bool "Build GRUB images (Linux x86 or x86_64 host only)"
depends TARGET_x86
depends TARGET_ROOTFS_EXT2FS || TARGET_ROOTFS_JFFS2 || TARGET_ROOTFS_SQUASHFS || TARGET_ROOTFS_ISO
+ select PACKAGE_grub
default y
config X86_GRUB_IMAGES_PAD
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index d470fe1c5f..095d40240b 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -14,14 +14,6 @@ ROOTPART=$(strip $(subst ",, $(CONFIG_X86_GRUB_ROOTPART)))
ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
- define Build/Compile
- $(MAKE) -C grub compile
- endef
-
- define Build/Clean
- $(MAKE) -C grub clean
- endef
-
define Image/cmdline/squashfs
block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=squashfs init=/etc/preinit
endef