aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-05-08 10:25:58 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-05-08 10:25:58 +0000
commit9906022f623093d61d9e0ad19422fbb2b987d329 (patch)
tree7362e62caaa0542f0058b07bd14e4ff3ff46e259
parent08d7c166223938444ecdfd87b7f58781fb418da9 (diff)
downloadupstream-9906022f623093d61d9e0ad19422fbb2b987d329.tar.gz
upstream-9906022f623093d61d9e0ad19422fbb2b987d329.tar.bz2
upstream-9906022f623093d61d9e0ad19422fbb2b987d329.zip
[package] base-files: retrigger usb coldplug after module loading, solves usb_modeswitch on boot and possibly others (#9352)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26848 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/base-files/Makefile2
-rwxr-xr-xpackage/base-files/files/etc/init.d/boot5
2 files changed, 6 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 95ab5a7c17..c10f483270 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=base-files
-PKG_RELEASE:=68
+PKG_RELEASE:=69
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
PKG_BUILD_DEPENDS:=opkg/host
diff --git a/package/base-files/files/etc/init.d/boot b/package/base-files/files/etc/init.d/boot
index c3019df04e..357ae3f31d 100755
--- a/package/base-files/files/etc/init.d/boot
+++ b/package/base-files/files/etc/init.d/boot
@@ -80,6 +80,11 @@ start() {
}
load_modules /etc/modules.d/*
+
+ # another round of USB coldplugging to kick devices into operation which lacked drivers before
+ for dev in /sys/bus/usb/devices/*/uevent; do
+ [ -e "$dev" ] && echo -n add > "$dev"
+ done
}
stop() {