aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-11-16 03:11:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-11-16 03:11:17 +0000
commit95145c4dd9736a628601672ce9e603b5b9f28c48 (patch)
tree6f19bb53f78baf73388d1bc0c6e785fda3b680f9
parent45fb09db51a10d04cd796d4ec7907cc349ad240d (diff)
downloadupstream-95145c4dd9736a628601672ce9e603b5b9f28c48.tar.gz
upstream-95145c4dd9736a628601672ce9e603b5b9f28c48.tar.bz2
upstream-95145c4dd9736a628601672ce9e603b5b9f28c48.zip
create broadcom initramfs images and move the lzma decompressor area a bit further
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9556 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/brcm-2.4/image/Makefile4
-rw-r--r--target/linux/brcm-2.4/image/lzma-loader/src/Makefile2
2 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/brcm-2.4/image/Makefile b/target/linux/brcm-2.4/image/Makefile
index 51975fe702..11192935cb 100644
--- a/target/linux/brcm-2.4/image/Makefile
+++ b/target/linux/brcm-2.4/image/Makefile
@@ -78,6 +78,10 @@ define Image/Build/squashfs
$(call Image/Build/jffs2-128k,$(1))
endef
+define Image/Build/Initramfs
+ $(STAGING_DIR_HOST)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-initramfs.trx -f $(KDIR)/loader.gz -f $(KDIR)/vmlinux.lzma
+endef
+
define Image/Build
$(STAGING_DIR_HOST)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(1).trx -f $(KDIR)/loader.gz -f $(KDIR)/vmlinux.lzma $(call trxalign/$(1),$(1))
$(call Image/Build/$(1),$(1))
diff --git a/target/linux/brcm-2.4/image/lzma-loader/src/Makefile b/target/linux/brcm-2.4/image/lzma-loader/src/Makefile
index 85a864674b..3320e565d0 100644
--- a/target/linux/brcm-2.4/image/lzma-loader/src/Makefile
+++ b/target/linux/brcm-2.4/image/lzma-loader/src/Makefile
@@ -18,7 +18,7 @@
#
TEXT_START := 0x80001000
-BZ_TEXT_START := 0x80300000
+BZ_TEXT_START := 0x80400000
OBJCOPY := $(CROSS_COMPILE)objcopy -O binary -R .reginfo -R .note -R .comment -R .mdebug -S