aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-01-18 16:46:57 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-01-18 16:46:57 +0000
commit8ff92f31d9d05d7f8868ac70acf97cbfce75061f (patch)
tree270a19af15ee4e59146cb891808bfaade594dbc4
parent07572fe9d33a33e2c1940eee5e25c5774a5ddfaf (diff)
downloadupstream-8ff92f31d9d05d7f8868ac70acf97cbfce75061f.tar.gz
upstream-8ff92f31d9d05d7f8868ac70acf97cbfce75061f.tar.bz2
upstream-8ff92f31d9d05d7f8868ac70acf97cbfce75061f.zip
ar71xx: create rescue image for the WZR-HP-G300NH
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19223 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/ar71xx/image/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index d3baec69e1..09d743c479 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -129,6 +129,10 @@ define Image/Build/WZRHPG300NH
dd if=$(KDIR)/vmlinux-$(2).uImage bs=1024k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
) > $(call imgname,$(1),$(2))-sysupgrade.bin; \
+ ( \
+ echo -n -e "# Airstation Public Fmt1\x00\x00\x00\x00\x00\x00\x00\x00"; \
+ dd if=$(call imgname,$(1),$(2))-sysupgrade.bin; \
+ ) > $(call imgname,$(1),$(2))-tftp.bin; \
fi; fi
endef