aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-04-26 18:27:51 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-04-26 18:27:51 +0000
commit8e9a9d267a574fc6bb8d69a747ce116c9063bedd (patch)
treeb6320970e332c7f3df316e84a6f41cb9ee3de50c
parent0656f01bd8b5dd902063ff98c051b808240b156d (diff)
downloadupstream-8e9a9d267a574fc6bb8d69a747ce116c9063bedd.tar.gz
upstream-8e9a9d267a574fc6bb8d69a747ce116c9063bedd.tar.bz2
upstream-8e9a9d267a574fc6bb8d69a747ce116c9063bedd.zip
ar71xx: create firmware images for the TL-WR941ND v3 boards
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21169 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/ar71xx/image/Makefile5
-rw-r--r--target/linux/ar71xx/profiles/tp-link.mk11
2 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index a5f02703c9..dfcc5f6f08 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -518,6 +518,10 @@ define Image/Build/Profile/TLWR941NDV2
$(call Image/Build/Template/$(fs_squash)/$(1),TPLINK,tl-wr941nd-v2,board=TL-WR941ND,TL-WR941NDv2)
endef
+define Image/Build/Profile/TLWR941NDV3
+ $(call Image/Build/Template/$(fs_squash)/$(1),TPLINK,tl-wr941nd-v3,board=TL-WR941ND,TL-WR941NDv2)
+endef
+
define Image/Build/Profile/TLWR941NDV4
$(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-wr941nd-v4,board=TL-WR741ND,TL-WR941NDv4)
endef
@@ -566,6 +570,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/TLWR841NDV3,$(1))
$(call Image/Build/Profile/TLWR841NDV5,$(1))
$(call Image/Build/Profile/TLWR941NDV2,$(1))
+ $(call Image/Build/Profile/TLWR941NDV3,$(1))
$(call Image/Build/Profile/TLWR941NDV4,$(1))
$(call Image/Build/Profile/TLWR1043NDV1,$(1))
$(call Image/Build/Profile/UBNT,$(1))
diff --git a/target/linux/ar71xx/profiles/tp-link.mk b/target/linux/ar71xx/profiles/tp-link.mk
index ffb3b9e06d..7efb1a3766 100644
--- a/target/linux/ar71xx/profiles/tp-link.mk
+++ b/target/linux/ar71xx/profiles/tp-link.mk
@@ -60,6 +60,17 @@ endef
$(eval $(call Profile,TLWR941NDV2))
+define Profile/TLWR941NDV3
+ NAME:=TP-LINK TL-WR941ND v3
+ PACKAGES:=kmod-ath9k wpad-mini
+endef
+
+define Profile/TLWR941NDV3/Description
+ Package set optimized for the TP-LINK TL-WR941ND v3.
+endef
+
+$(eval $(call Profile,TLWR941NDV3))
+
define Profile/TLWR941NDV4
NAME:=TP-LINK TL-WR941ND v4
PACKAGES:=kmod-ath9k wpad-mini