aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-07-06 11:17:41 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-07-06 11:17:41 +0000
commit754379d9b227a13ad43f04a7d2b31c08b6764e49 (patch)
tree1b11190c65104abc98a8bf6ad327de80d96956a0
parenta5dd7363e31e6cc01ccff109bfc93b7dcc852e03 (diff)
downloadupstream-754379d9b227a13ad43f04a7d2b31c08b6764e49.tar.gz
upstream-754379d9b227a13ad43f04a7d2b31c08b6764e49.tar.bz2
upstream-754379d9b227a13ad43f04a7d2b31c08b6764e49.zip
package/busybox: fix sed issue with gcc-4.5.0 (closes #7566)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22074 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/busybox/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index aa51b17c8d..128a0dea18 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -60,6 +60,10 @@ ifdef CONFIG_GCC_VERSION_LLVM
TARGET_CFLAGS += -fnested-functions
endif
+ifdef CONFIG_GCC_VERSION_4_5_0
+ TARGET_CFLAGS += -fno-tree-pta
+endif
+
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \