aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2010-03-24 15:53:48 +0000
committerJohn Crispin <blogic@openwrt.org>2010-03-24 15:53:48 +0000
commit723509ef72d6823bd791f072613f44dd3235a930 (patch)
tree8de09e56fb2b6fd56fd8ed82bea2406d6032fe5b
parentdc667aa725cd6900fd17ab51e03613cbe9afa566 (diff)
downloadupstream-723509ef72d6823bd791f072613f44dd3235a930.tar.gz
upstream-723509ef72d6823bd791f072613f44dd3235a930.tar.bz2
upstream-723509ef72d6823bd791f072613f44dd3235a930.zip
[ifxmips] meta partition should not span brn-boot sector
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20401 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/ifxmips/patches-2.6.30/140-mtd.patch9
1 files changed, 5 insertions, 4 deletions
diff --git a/target/linux/ifxmips/patches-2.6.30/140-mtd.patch b/target/linux/ifxmips/patches-2.6.30/140-mtd.patch
index 294d97335e..184c78ca98 100644
--- a/target/linux/ifxmips/patches-2.6.30/140-mtd.patch
+++ b/target/linux/ifxmips/patches-2.6.30/140-mtd.patch
@@ -1,7 +1,7 @@
Index: linux-2.6.30.10/drivers/mtd/maps/Makefile
===================================================================
---- linux-2.6.30.10.orig/drivers/mtd/maps/Makefile 2010-03-18 14:27:04.000000000 +0100
-+++ linux-2.6.30.10/drivers/mtd/maps/Makefile 2010-03-18 14:27:07.000000000 +0100
+--- linux-2.6.30.10.orig/drivers/mtd/maps/Makefile 2009-12-04 07:00:07.000000000 +0100
++++ linux-2.6.30.10/drivers/mtd/maps/Makefile 2010-03-24 15:32:04.000000000 +0100
@@ -62,3 +62,4 @@
obj-$(CONFIG_MTD_BFIN_ASYNC) += bfin-async-flash.o
obj-$(CONFIG_MTD_RBTX4939) += rbtx4939-flash.o
@@ -10,8 +10,8 @@ Index: linux-2.6.30.10/drivers/mtd/maps/Makefile
Index: linux-2.6.30.10/drivers/mtd/maps/ifxmips.c
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.30.10/drivers/mtd/maps/ifxmips.c 2010-03-18 14:27:17.000000000 +0100
-@@ -0,0 +1,281 @@
++++ linux-2.6.30.10/drivers/mtd/maps/ifxmips.c 2010-03-24 16:46:26.000000000 +0100
+@@ -0,0 +1,282 @@
+/*
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
@@ -253,6 +253,7 @@ Index: linux-2.6.30.10/drivers/mtd/maps/ifxmips.c
+ parts[3].size -= ifxmips_mtd->erasesize;
+ parts[4].offset = ifxmips_mtd->size - ifxmips_mtd->erasesize;
+ parts[4].size = ifxmips_mtd->erasesize;
++ ifxmips_meta_partition.size -= ifxmips_mtd->erasesize;
+ } else {
+ num_parts--;
+ }