aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-10-22 19:50:35 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-10-22 19:50:35 +0000
commit6ee2c2b79cdd118e49d28a28ae5c69b0b0553581 (patch)
treedd7534a1132f094eca30c4d95e229424f9d441e1
parent59bf9e97faaa919350263ffcdc1654d5c9cab775 (diff)
downloadupstream-6ee2c2b79cdd118e49d28a28ae5c69b0b0553581.tar.gz
upstream-6ee2c2b79cdd118e49d28a28ae5c69b0b0553581.tar.bz2
upstream-6ee2c2b79cdd118e49d28a28ae5c69b0b0553581.zip
[package] firewall: do not check for module availability, let iptables fail if a feature is not present (#7610)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28525 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/firewall/Makefile2
-rw-r--r--package/firewall/files/lib/fw.sh16
2 files changed, 2 insertions, 16 deletions
diff --git a/package/firewall/Makefile b/package/firewall/Makefile
index 597a37e140..749f04a4b1 100644
--- a/package/firewall/Makefile
+++ b/package/firewall/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=firewall
PKG_VERSION:=2
-PKG_RELEASE:=35
+PKG_RELEASE:=36
include $(INCLUDE_DIR)/package.mk
diff --git a/package/firewall/files/lib/fw.sh b/package/firewall/files/lib/fw.sh
index a13eb7eb13..bf7156e8ce 100644
--- a/package/firewall/files/lib/fw.sh
+++ b/package/firewall/files/lib/fw.sh
@@ -74,21 +74,7 @@ fw__exec() { # <action> <family> <table> <chain> <target> <position> { <rules> }
fw__rc $(($? & 1))
return
fi
- local mod
- eval "mod=\$FW_${fam#G}_${tab}"
- if [ "$mod" ]; then
- fw__rc $mod
- return
- fi
- case "$fam" in
- *4) mod=iptable_${tab} ;;
- *6) mod=ip6table_${tab} ;;
- *) mod=. ;;
- esac
- grep -q "^${mod} " /proc/modules
- mod=$?
- export FW_${fam}_${tab}=$mod
- fw__rc $mod
+ fw__rc 0
}
fw__err() {