aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-03-15 09:25:53 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-03-15 09:25:53 +0000
commit6189648864db8ae11feb600fc53ac2fee556707d (patch)
tree5646adfc060b75071b8d89b96236a019503dff81
parent9af0d919e6a06567d705547ec13603de00372ebe (diff)
downloadupstream-6189648864db8ae11feb600fc53ac2fee556707d.tar.gz
upstream-6189648864db8ae11feb600fc53ac2fee556707d.tar.bz2
upstream-6189648864db8ae11feb600fc53ac2fee556707d.zip
ar71xx: move micrel PHY driver to the generic linux target
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30946 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/generic/files/drivers/net/phy/micrel.c (renamed from target/linux/ar71xx/files/drivers/net/phy/micrel.c)0
-rw-r--r--target/linux/generic/patches-3.2/728-phy-micrel.patch (renamed from target/linux/ar71xx/patches-3.2/421-net-ksz8041_phy_driver.patch)4
-rw-r--r--target/linux/generic/patches-3.3/728-phy-micrel.patch (renamed from target/linux/ar71xx/patches-3.3/421-net-ksz8041_phy_driver.patch)4
3 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/ar71xx/files/drivers/net/phy/micrel.c b/target/linux/generic/files/drivers/net/phy/micrel.c
index 1499d4ace4..1499d4ace4 100644
--- a/target/linux/ar71xx/files/drivers/net/phy/micrel.c
+++ b/target/linux/generic/files/drivers/net/phy/micrel.c
diff --git a/target/linux/ar71xx/patches-3.2/421-net-ksz8041_phy_driver.patch b/target/linux/generic/patches-3.2/728-phy-micrel.patch
index 78d7e0e3eb..8272ba7caa 100644
--- a/target/linux/ar71xx/patches-3.2/421-net-ksz8041_phy_driver.patch
+++ b/target/linux/generic/patches-3.2/728-phy-micrel.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -124,6 +124,11 @@ config RTL8306_PHY
+@@ -128,6 +128,11 @@ config RTL8306_PHY
tristate "Driver for Realtek RTL8306S switches"
select SWCONFIG
@@ -14,7 +14,7 @@
depends on PHYLIB=y
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
-@@ -25,6 +25,7 @@ obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
+@@ -27,6 +27,7 @@ obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
diff --git a/target/linux/ar71xx/patches-3.3/421-net-ksz8041_phy_driver.patch b/target/linux/generic/patches-3.3/728-phy-micrel.patch
index 78d7e0e3eb..8272ba7caa 100644
--- a/target/linux/ar71xx/patches-3.3/421-net-ksz8041_phy_driver.patch
+++ b/target/linux/generic/patches-3.3/728-phy-micrel.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -124,6 +124,11 @@ config RTL8306_PHY
+@@ -128,6 +128,11 @@ config RTL8306_PHY
tristate "Driver for Realtek RTL8306S switches"
select SWCONFIG
@@ -14,7 +14,7 @@
depends on PHYLIB=y
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
-@@ -25,6 +25,7 @@ obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
+@@ -27,6 +27,7 @@ obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o