aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTravis Kemen <thepeople@openwrt.org>2007-11-28 04:07:24 +0000
committerTravis Kemen <thepeople@openwrt.org>2007-11-28 04:07:24 +0000
commit5a53807f3dc0e2fc5f9ae6985e7e81181fc3e7f0 (patch)
treec80a15354fb21889c5c9fc4f0cf2ee6df271023b
parentb9eb6f4a6479f9bd9df14f1738d1f48d55166238 (diff)
downloadupstream-5a53807f3dc0e2fc5f9ae6985e7e81181fc3e7f0.tar.gz
upstream-5a53807f3dc0e2fc5f9ae6985e7e81181fc3e7f0.tar.bz2
upstream-5a53807f3dc0e2fc5f9ae6985e7e81181fc3e7f0.zip
add support for the PCEngines Alix
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9611 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/x86/config-2.6.232
-rw-r--r--target/linux/x86/generic/profiles/Alix.mk16
2 files changed, 17 insertions, 1 deletions
diff --git a/target/linux/x86/config-2.6.23 b/target/linux/x86/config-2.6.23
index d04514b161..c12a2f95cf 100644
--- a/target/linux/x86/config-2.6.23
+++ b/target/linux/x86/config-2.6.23
@@ -349,7 +349,7 @@ CONFIG_USB_UHCI_HCD=m
# CONFIG_VGASTATE is not set
CONFIG_VGA_CONSOLE=y
CONFIG_VIA_RHINE=m
-# CONFIG_VIA_RHINE_MMIO is not set
+CONFIG_VIA_RHINE_MMIO=y
CONFIG_VIA_RHINE_NAPI=y
# CONFIG_VIDEO_SELECT is not set
# CONFIG_VIRTUALIZATION is not set
diff --git a/target/linux/x86/generic/profiles/Alix.mk b/target/linux/x86/generic/profiles/Alix.mk
new file mode 100644
index 0000000000..24f5bf1306
--- /dev/null
+++ b/target/linux/x86/generic/profiles/Alix.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Alix
+ NAME:=PCEngines Alix
+ PACKAGES:=kmod-via-rhine
+endef
+
+define Profile/Alix/Description
+ Package set compatible with the PCEngines Alix. Contains VIA Rhine III VT6105M support
+endef
+$(eval $(call Profile,Alix))