aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-01-20 21:09:04 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-01-20 21:09:04 +0000
commit58fcf1d2914d46fa0438f01a530e52ca6ae5cec5 (patch)
treee4cf387a65cfcb8690413c08f6c22dc3d6df1604
parent05fe275a90fdd33d0de8a361d32eeeb1621ccb86 (diff)
downloadupstream-58fcf1d2914d46fa0438f01a530e52ca6ae5cec5.tar.gz
upstream-58fcf1d2914d46fa0438f01a530e52ca6ae5cec5.tar.bz2
upstream-58fcf1d2914d46fa0438f01a530e52ca6ae5cec5.zip
add a menuconfig option for enabling KALLSYMS for the kernel
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14122 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--Config.in8
-rw-r--r--include/kernel-defaults.mk3
2 files changed, 11 insertions, 0 deletions
diff --git a/Config.in b/Config.in
index a5b3364612..0f131f0623 100644
--- a/Config.in
+++ b/Config.in
@@ -117,6 +117,14 @@ config NO_STRIP
bool "Install unstripped binary on the target (useful for native compiling/debugging)"
default n
+comment "Kernel build options"
+
+config KERNEL_KALLSYMS
+ bool "Compile the kernel with symbol table information"
+ default n
+ help
+ This will give you more information in stack traces from kernel oopses
+
endmenu
menuconfig DEVEL
diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index 36f9174c91..4aa5c0ef18 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -86,6 +86,9 @@ define Kernel/Configure/2.6
endef
define Kernel/Configure/Default
$(LINUX_CONFCMD) > $(LINUX_DIR)/.config.target
+ echo "$(if $(CONFIG_KERNEL_KALLSYMS),CONFIG_KALLSYMS=y,# CONFIG_KALLSYMS is not set)" >> $(LINUX_DIR)/.config.target
+ echo "# CONFIG_KALLSYMS_EXTRA_PASS is not set" >> $(LINUX_DIR)/.config.target
+ echo "# CONFIG_KPROBES is not set" >> $(LINUX_DIR)/.config.target
$(SCRIPT_DIR)/metadata.pl kconfig $(TMP_DIR)/.packageinfo $(TOPDIR)/.config > $(LINUX_DIR)/.config.override
$(SCRIPT_DIR)/kconfig.pl 'm+' $(LINUX_DIR)/.config.target $(LINUX_DIR)/.config.override > $(LINUX_DIR)/.config
$(call Kernel/SetInitramfs)