aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-12-19 02:53:02 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-12-19 02:53:02 +0000
commit4c5d5d43079bd56aa97623955b859c37f2c288ea (patch)
treec8b9267068ac5c5d3f84799af705c10f8142773c
parent3851c5fd51b3f8eb41043442b9df2ae04d6c22b2 (diff)
downloadupstream-4c5d5d43079bd56aa97623955b859c37f2c288ea.tar.gz
upstream-4c5d5d43079bd56aa97623955b859c37f2c288ea.tar.bz2
upstream-4c5d5d43079bd56aa97623955b859c37f2c288ea.zip
fix qos-scripts RED qdisc calculation for slow lines
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5853 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/qos-scripts/Makefile2
-rwxr-xr-xpackage/qos-scripts/files/usr/lib/qos.sh1
2 files changed, 2 insertions, 1 deletions
diff --git a/package/qos-scripts/Makefile b/package/qos-scripts/Makefile
index 86eb6b3a23..bb5a9639f1 100644
--- a/package/qos-scripts/Makefile
+++ b/package/qos-scripts/Makefile
@@ -9,7 +9,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=qos-scripts
-PKG_VERSION:=0.9.3
+PKG_VERSION:=0.9.4
PKG_RELEASE:=1
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
diff --git a/package/qos-scripts/files/usr/lib/qos.sh b/package/qos-scripts/files/usr/lib/qos.sh
index 8fcf9dc27f..724784ebd0 100755
--- a/package/qos-scripts/files/usr/lib/qos.sh
+++ b/package/qos-scripts/files/usr/lib/qos.sh
@@ -275,6 +275,7 @@ BEGIN {
print "sfq perturb 10 limit " cqlen
} else {
avpkt = 1200
+ if (min < avpkt) min = avpkt
min = int(limit * 1024 / 8 * 0.1)
dqb = cqlen * 1500
max = int(min + (dqb - min) * 0.25)