aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-03-14 19:27:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-03-14 19:27:45 +0000
commit4715bfd68c109c8e9f0ded23121fb6c0c21d05a9 (patch)
tree6708aac7984af585623a3af61c96b123db90971e
parent2c83fb0ef4b254490e2d514ebdf4b75226736760 (diff)
downloadupstream-4715bfd68c109c8e9f0ded23121fb6c0c21d05a9.tar.gz
upstream-4715bfd68c109c8e9f0ded23121fb6c0c21d05a9.tar.bz2
upstream-4715bfd68c109c8e9f0ded23121fb6c0c21d05a9.zip
base-files: link libpthread against libc
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26161 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/base-files/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index b7fb07309e..60f9f83b5c 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -362,7 +362,7 @@ ifneq ($(BUILD_LIBGCC),)
"$(wildcard $(TOOLCHAIN_DIR)/lib/libpthread_so.a)" \
"$(patsubst $(TOOLCHAIN_DIR)/lib/%,$(PKG_BUILD_DIR)/%,$(wildcard $(TOOLCHAIN_DIR)/lib/libpthread-*.so))" \
-Wl,-z,nodelete,-z,initfirst,-init=__pthread_initialize_minimal_internal \
- -ldl $(BUILD_LIBGCC) \
+ -ldl -lc $(BUILD_LIBGCC) \
-Wl,-soname=libpthread.so.0
endef
define Build/Compile/libgcc