aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-06-15 07:13:00 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-06-15 07:13:00 +0000
commit44e0ac47f47cc971ee632356a67dee37bb75f627 (patch)
tree41968e70623b180c3a55c39dd9d10b3b31ae9e16
parentd6ced93638d2660ab7dc3e82a257f5f5a77e9d2c (diff)
downloadupstream-44e0ac47f47cc971ee632356a67dee37bb75f627.tar.gz
upstream-44e0ac47f47cc971ee632356a67dee37bb75f627.tar.bz2
upstream-44e0ac47f47cc971ee632356a67dee37bb75f627.zip
rfkill config cleanup
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16471 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/kernel/modules/other.mk2
-rw-r--r--target/linux/brcm47xx/config-2.6.282
-rw-r--r--target/linux/brcm47xx/config-2.6.302
-rw-r--r--target/linux/ifxmips/config-2.6.271
-rw-r--r--target/linux/ixp4xx/config-2.6.271
-rw-r--r--target/linux/ixp4xx/config-2.6.281
-rw-r--r--target/linux/ixp4xx/config-default1
-rw-r--r--target/linux/olpc/config-2.6.271
-rw-r--r--target/linux/ppc40x/config-default1
-rw-r--r--target/linux/s3c24xx/config-2.6.283
-rw-r--r--target/linux/s3c24xx/config-2.6.293
-rw-r--r--target/linux/s3c24xx/config-2.6.303
12 files changed, 1 insertions, 20 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 309e25b929..74905e1234 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -761,7 +761,7 @@ $(eval $(call KernelPackage,textsearch))
define KernelPackage/rfkill
SUBMENU:=$(OTHER_MENU)
TITLE:=RF switch subsystem support
- DEPENDS:=@LINUX_2_6 @!LINUX_2_6_21 @!TARGET_rb532 @!TARGET_avr32 @!TARGET_brcm47xx @!TARGET_s3c24xx @!TARGET_ifxmips @!TARGET_atheros @!TARGET_adm5120 @!TARGET_ar7 @!TARGET_ppc40x @!TARGET_ixp4xx @!TARGET_rdc @!TARGET_uml
+ DEPENDS:=@TARGET_x86||TARGET_olpc||TARGET_s3c24xx||TARGET_brcm47xx
KCONFIG:= \
CONFIG_RFKILL \
CONFIG_RFKILL_INPUT \
diff --git a/target/linux/brcm47xx/config-2.6.28 b/target/linux/brcm47xx/config-2.6.28
index 8b6248ed67..fd7ffeedf6 100644
--- a/target/linux/brcm47xx/config-2.6.28
+++ b/target/linux/brcm47xx/config-2.6.28
@@ -121,8 +121,6 @@ CONFIG_PHYLIB=y
# CONFIG_PROC_KCORE is not set
# CONFIG_PROM_EMU is not set
# CONFIG_R6040 is not set
-CONFIG_RFKILL=y
-CONFIG_RFKILL_LEDS=y
CONFIG_SCHED_NO_NO_OMIT_FRAME_POINTER=y
# CONFIG_SCSI_DMA is not set
# CONFIG_SERIAL_8250_DETECT_IRQ is not set
diff --git a/target/linux/brcm47xx/config-2.6.30 b/target/linux/brcm47xx/config-2.6.30
index f027b2c607..967c586f93 100644
--- a/target/linux/brcm47xx/config-2.6.30
+++ b/target/linux/brcm47xx/config-2.6.30
@@ -130,8 +130,6 @@ CONFIG_PHYLIB=y
# CONFIG_PROBE_INITRD_HEADER is not set
# CONFIG_PROC_KCORE is not set
# CONFIG_PROM_EMU is not set
-CONFIG_RFKILL=y
-CONFIG_RFKILL_LEDS=y
CONFIG_SCHED_OMIT_FRAME_POINTER=y
# CONFIG_SCSI_DMA is not set
# CONFIG_SERIAL_8250_DETECT_IRQ is not set
diff --git a/target/linux/ifxmips/config-2.6.27 b/target/linux/ifxmips/config-2.6.27
index aba12863fc..b2fb156da9 100644
--- a/target/linux/ifxmips/config-2.6.27
+++ b/target/linux/ifxmips/config-2.6.27
@@ -131,7 +131,6 @@ CONFIG_PCI_DOMAINS=y
# CONFIG_PROBE_INITRD_HEADER is not set
# CONFIG_PROM_EMU is not set
# CONFIG_R6040 is not set
-CONFIG_RFKILL_LEDS=y
CONFIG_SCHED_NO_NO_OMIT_FRAME_POINTER=y
# CONFIG_SCSI_WAIT_SCAN is not set
# CONFIG_SERIAL_8250 is not set
diff --git a/target/linux/ixp4xx/config-2.6.27 b/target/linux/ixp4xx/config-2.6.27
index ee226e7c66..223b30ae7c 100644
--- a/target/linux/ixp4xx/config-2.6.27
+++ b/target/linux/ixp4xx/config-2.6.27
@@ -175,7 +175,6 @@ CONFIG_PAGEFLAGS_EXTENDED=y
CONFIG_PCI=y
CONFIG_PCI_SYSCALL=y
# CONFIG_R6040 is not set
-CONFIG_RFKILL_LEDS=y
CONFIG_RTC_CLASS=y
CONFIG_RTC_DRV_DS1672=y
CONFIG_RTC_DRV_ISL1208=y
diff --git a/target/linux/ixp4xx/config-2.6.28 b/target/linux/ixp4xx/config-2.6.28
index 4360a4c8de..9807446614 100644
--- a/target/linux/ixp4xx/config-2.6.28
+++ b/target/linux/ixp4xx/config-2.6.28
@@ -178,7 +178,6 @@ CONFIG_PAGEFLAGS_EXTENDED=y
CONFIG_PCI=y
CONFIG_PCI_SYSCALL=y
# CONFIG_R6040 is not set
-CONFIG_RFKILL_LEDS=y
CONFIG_RTC_CLASS=y
CONFIG_RTC_DRV_DS1672=y
CONFIG_RTC_DRV_ISL1208=y
diff --git a/target/linux/ixp4xx/config-default b/target/linux/ixp4xx/config-default
index 9c48b880f3..d1e1656986 100644
--- a/target/linux/ixp4xx/config-default
+++ b/target/linux/ixp4xx/config-default
@@ -208,7 +208,6 @@ CONFIG_PCI=y
CONFIG_PCI_SYSCALL=y
# CONFIG_PRISM54 is not set
# CONFIG_R6040 is not set
-CONFIG_RFKILL_LEDS=y
CONFIG_RTC_CLASS=y
CONFIG_RTC_DRV_DS1672=y
CONFIG_RTC_DRV_ISL1208=y
diff --git a/target/linux/olpc/config-2.6.27 b/target/linux/olpc/config-2.6.27
index 2800b77833..54994ac53e 100644
--- a/target/linux/olpc/config-2.6.27
+++ b/target/linux/olpc/config-2.6.27
@@ -490,7 +490,6 @@ CONFIG_PROFILING=y
# CONFIG_RCU_TORTURE_TEST is not set
CONFIG_RELAY=y
# CONFIG_RELOCATABLE is not set
-# CONFIG_RFKILL is not set
CONFIG_RTC=y
# CONFIG_RT_MUTEX_TESTER is not set
# CONFIG_RWSEM_GENERIC_SPINLOCK is not set
diff --git a/target/linux/ppc40x/config-default b/target/linux/ppc40x/config-default
index 66b3e89289..51eeebd762 100644
--- a/target/linux/ppc40x/config-default
+++ b/target/linux/ppc40x/config-default
@@ -155,7 +155,6 @@ CONFIG_PPC_UDBG_16550=y
CONFIG_PROC_DEVICETREE=y
# CONFIG_R6040 is not set
CONFIG_RESOURCES_64BIT=y
-CONFIG_RFKILL_LEDS=y
CONFIG_RWSEM_XCHGADD_ALGORITHM=y
# CONFIG_SCHED_HRTICK is not set
CONFIG_SCHED_NO_NO_OMIT_FRAME_POINTER=y
diff --git a/target/linux/s3c24xx/config-2.6.28 b/target/linux/s3c24xx/config-2.6.28
index 67da70dfaf..3e3931255c 100644
--- a/target/linux/s3c24xx/config-2.6.28
+++ b/target/linux/s3c24xx/config-2.6.28
@@ -360,9 +360,6 @@ CONFIG_PROC_PAGE_MONITOR=y
CONFIG_REGULATOR=y
CONFIG_REGULATOR_DEBUG=y
CONFIG_REGULATOR_PCF50633=y
-CONFIG_RFKILL=y
-CONFIG_RFKILL_INPUT=y
-CONFIG_RFKILL_LEDS=y
CONFIG_RTC_CLASS=y
CONFIG_RTC_DEBUG=y
# CONFIG_RTC_DRV_CMOS is not set
diff --git a/target/linux/s3c24xx/config-2.6.29 b/target/linux/s3c24xx/config-2.6.29
index 3a7e323154..a6695e79a8 100644
--- a/target/linux/s3c24xx/config-2.6.29
+++ b/target/linux/s3c24xx/config-2.6.29
@@ -366,9 +366,6 @@ CONFIG_REGULATOR=y
CONFIG_REGULATOR_DEBUG=y
CONFIG_REGULATOR_PCF50606=y
CONFIG_REGULATOR_PCF50633=y
-CONFIG_RFKILL=y
-CONFIG_RFKILL_INPUT=y
-CONFIG_RFKILL_LEDS=y
CONFIG_RTC_CLASS=y
# CONFIG_RTC_DRV_CMOS is not set
CONFIG_RTC_DRV_PCF50606=y
diff --git a/target/linux/s3c24xx/config-2.6.30 b/target/linux/s3c24xx/config-2.6.30
index 5dcd0b66db..4bb2e88cef 100644
--- a/target/linux/s3c24xx/config-2.6.30
+++ b/target/linux/s3c24xx/config-2.6.30
@@ -307,9 +307,6 @@ CONFIG_RD_GZIP=y
CONFIG_REGULATOR=y
# CONFIG_REGULATOR_DEBUG is not set
CONFIG_REGULATOR_PCF50633=y
-CONFIG_RFKILL=y
-CONFIG_RFKILL_INPUT=y
-CONFIG_RFKILL_LEDS=y
CONFIG_RTC_CLASS=y
# CONFIG_RTC_DRV_CMOS is not set
CONFIG_RTC_DRV_PCF50633=y