aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Dickinson <daniel@cshore.neomailbox.net>2012-02-16 07:29:26 +0000
committerDaniel Dickinson <daniel@cshore.neomailbox.net>2012-02-16 07:29:26 +0000
commit3be148b333251f9313ec2a66d8235966bd1f7bb1 (patch)
treedc603589e61fbb7bec4700fe22b1fcfbb9033c71
parent190f75f1042a2c9eb27a7f484ebe180b9e9d2421 (diff)
downloadupstream-3be148b333251f9313ec2a66d8235966bd1f7bb1.tar.gz
upstream-3be148b333251f9313ec2a66d8235966bd1f7bb1.tar.bz2
upstream-3be148b333251f9313ec2a66d8235966bd1f7bb1.zip
[ar71xx] Fix partitions for Cameo-based boards; kernel 3.2 is bigger
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30569 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/ar71xx/image/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 2caa58637d..2cde9cb679 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -206,14 +206,14 @@ define Image/Build/Cameo
fi
endef
-cameo913x_mtdlayout=mtdparts=spi0.0:128k(u-boot)ro,64k(config)ro,896k(kernel),2944k(rootfs),64k(art)ro,3840k@0x30000(firmware)
+cameo913x_mtdlayout=mtdparts=spi0.0:128k(u-boot)ro,64k(config)ro,960k(kernel),2880k(rootfs),64k(art)ro,3840k@0x30000(firmware)
define Image/Build/Cameo913x
- $(call Image/Build/Cameo,$(1),$(2),$(3),$(cameo913x_mtdlayout),917504,2949120,$(4))
+ $(call Image/Build/Cameo,$(1),$(2),$(3),$(cameo913x_mtdlayout),983040,2949120,$(4))
endef
-cameo7240_mtdlayout=mtdparts=spi0.0:192k(u-boot)ro,64k(nvram)ro,896k(kernel),2816k(rootfs),64k(mac)ro,64k(art)ro,3712k@0x40000(firmware)
+cameo7240_mtdlayout=mtdparts=spi0.0:192k(u-boot)ro,64k(nvram)ro,960k(kernel),2752k(rootfs),64k(mac)ro,64k(art)ro,3712k@0x40000(firmware)
define Image/Build/Cameo7240
- $(call Image/Build/Cameo,$(1),$(2),$(3),$(cameo7240_mtdlayout),917504,2818048,$(4))
+ $(call Image/Build/Cameo,$(1),$(2),$(3),$(cameo7240_mtdlayout),983040,2818048,$(4))
endef
define Image/Build/Ath