aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-12-24 10:58:09 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-12-24 10:58:09 +0000
commit37216e75b4ac3dc9b5ad2f22d602b4966656319a (patch)
tree21eb640da137d44e84e0d888b86f40b7679bddfc
parentb97c4008bd4abe67aa135349ce879147098346bd (diff)
downloadupstream-37216e75b4ac3dc9b5ad2f22d602b4966656319a.tar.gz
upstream-37216e75b4ac3dc9b5ad2f22d602b4966656319a.tar.bz2
upstream-37216e75b4ac3dc9b5ad2f22d602b4966656319a.zip
add WRT300N v1.1 support (patch from #6379)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18921 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/broadcom-diag/src/diag.c17
-rwxr-xr-xtarget/linux/brcm-2.4/base-files/etc/init.d/netconfig6
-rw-r--r--target/linux/brcm-2.4/image/Makefile3
-rw-r--r--target/linux/brcm-2.4/profiles/WRT300Nv11.mk17
4 files changed, 40 insertions, 3 deletions
diff --git a/package/broadcom-diag/src/diag.c b/package/broadcom-diag/src/diag.c
index 89af0f7fc0..0b59ab12cf 100644
--- a/package/broadcom-diag/src/diag.c
+++ b/package/broadcom-diag/src/diag.c
@@ -61,6 +61,7 @@ enum {
WRTSL54GS,
WRT54G3G,
WRT160N,
+ WRT300NV11,
WRT350N,
WRT600N,
WRT600NV11,
@@ -255,6 +256,19 @@ static struct platform_t __initdata platforms[] = {
{ .name = "ses_orange", .gpio = 1 << 3, .polarity = REVERSE },
},
},
+ [WRT300NV11] = {
+ .name = "Linksys WRT300N V1.1",
+ .buttons = {
+ { .name = "reset", .gpio = 1 << 6 }, // "Reset" on back panel
+ { .name = "ses", .gpio = 1 << 4 }, // "Reserved" on top panel
+ },
+ .leds = {
+ { .name = "power", .gpio = 1 << 1, .polarity = NORMAL }, // "Power"
+ { .name = "ses_amber", .gpio = 1 << 3, .polarity = REVERSE }, // "Security" Amber
+ { .name = "ses_green", .gpio = 1 << 5, .polarity = REVERSE }, // "Security" Green
+ },
+ .platform_init = bcm57xx_init,
+ },
[WRT350N] = {
.name = "Linksys WRT350N",
.buttons = {
@@ -886,6 +900,9 @@ static struct platform_t __init *platform_detect(void)
if (startswith(getvar("pmon_ver"), "CFE")) {
/* CFE based - newer hardware */
if (!strcmp(boardnum, "42")) { /* Linksys */
+ if (!strcmp(boardtype, "0x478") && !strcmp(getvar("boot_hw_model"), "WRT300N") && !strcmp(getvar("boot_hw_ver"), "1.1"))
+ return &platforms[WRT300NV11];
+
if (!strcmp(boardtype, "0x478") && !strcmp(getvar("cardbus"), "1"))
return &platforms[WRT350N];
diff --git a/target/linux/brcm-2.4/base-files/etc/init.d/netconfig b/target/linux/brcm-2.4/base-files/etc/init.d/netconfig
index 638f664bef..d63f17b124 100755
--- a/target/linux/brcm-2.4/base-files/etc/init.d/netconfig
+++ b/target/linux/brcm-2.4/base-files/etc/init.d/netconfig
@@ -164,8 +164,10 @@ start() {
c["lan_ifname"] = "eth0"
c["wan_ifname"] = "eth1"
}
- if (nvram["boardtype"] == "0x478") {
- # generic broadcom 4785 processor with 5397 switch?
+ # generic broadcom 4705/4785 processor with 5397 switch?
+ # EXCEPT Linksys WRT300N V1.1
+ if ((nvram["boardtype"] == "0x478") && \
+ (model != "Linksys WRT300N V1.1")) {
c["vlan0ports"] = "1 2 3 4 8*"
c["vlan1ports"] = "0 8"
}
diff --git a/target/linux/brcm-2.4/image/Makefile b/target/linux/brcm-2.4/image/Makefile
index 39570200af..3dad1cee70 100644
--- a/target/linux/brcm-2.4/image/Makefile
+++ b/target/linux/brcm-2.4/image/Makefile
@@ -68,7 +68,8 @@ define Image/Build/jffs2-64k
$(call Image/Build/CyberTAN,$(1),wrt54g,W54G,4.71.1,$(patsubst jffs2-%,jffs2,$(1)))
$(call Image/Build/CyberTAN,$(1),wrt54gs_v4,W54s,1.09.1,$(patsubst jffs2-%,jffs2,$(1)))
$(call Image/Build/CyberTAN,$(1),wrt150n,N150,1.51.3,$(patsubst jffs2-%,jffs2,$(1)))
- $(call Image/Build/CyberTAN,$(1),wrt300n_v1,EWCB,1.51.2,$(patsubst jffs2-%,jffs2,$(1)))
+ $(call Image/Build/CyberTAN,$(1),wrt300n_v1,EWCB,1.03.6,$(patsubst jffs2-%,jffs2,$(1)))
+ $(call Image/Build/CyberTAN,$(1),wrt300n_v11,EWC2,1.51.2,$(patsubst jffs2-%,jffs2,$(1)))
$(call Image/Build/CyberTAN,$(1),wrt350n_v1,EWCG,1.04.1,$(patsubst jffs2-%,jffs2,$(1)))
$(call Image/Build/Motorola,$(1),wa840g,2,$(patsubst jffs2-%,jffs2,$(1)))
$(call Image/Build/Motorola,$(1),we800g,3,$(patsubst jffs2-%,jffs2,$(1)))
diff --git a/target/linux/brcm-2.4/profiles/WRT300Nv11.mk b/target/linux/brcm-2.4/profiles/WRT300Nv11.mk
new file mode 100644
index 0000000000..dddcd1424c
--- /dev/null
+++ b/target/linux/brcm-2.4/profiles/WRT300Nv11.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WRT300Nv11
+ NAME:=Linksys WRT300N v1.1
+ PACKAGES:=kmod-brcm-wl-mimo wlc nas kmod-wlcompat kmod-brcm-57xx
+endef
+
+define Profile/WRT300Nv11/Description
+ Package set optimized for the WRT300N v1.1
+endef
+$(eval $(call Profile,WRT300Nv11))
+