aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-11-25 16:22:35 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-11-25 16:22:35 +0000
commit2f79ae7c2e71d989ae52eafb5b91211ed20d308c (patch)
tree2c0d1b336bc72eeb57e81734f1e5f137392256ff
parent808c54dad7c966d96b0fb85c7111b804844633e8 (diff)
downloadupstream-2f79ae7c2e71d989ae52eafb5b91211ed20d308c.tar.gz
upstream-2f79ae7c2e71d989ae52eafb5b91211ed20d308c.tar.bz2
upstream-2f79ae7c2e71d989ae52eafb5b91211ed20d308c.zip
AA: ar71xx: create profile and build image for the OpenMesh MR600 board
Backport of r34237. Signed-off-by: Marek Lindner <lindner_marek@yahoo.de> Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@34352 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/ar71xx/generic/profiles/openmesh.mk11
-rw-r--r--target/linux/ar71xx/image/Makefile1
2 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/openmesh.mk b/target/linux/ar71xx/generic/profiles/openmesh.mk
index 975a7edf1d..92aec4b79c 100644
--- a/target/linux/ar71xx/generic/profiles/openmesh.mk
+++ b/target/linux/ar71xx/generic/profiles/openmesh.mk
@@ -16,3 +16,14 @@ endef
$(eval $(call Profile,OM2P))
+define Profile/MR600
+ NAME:=OpenMesh MR600
+ PACKAGES:=kmod-ath9k om-watchdog
+endef
+
+define Profile/MR600/Description
+ Package set optimized for the OpenMesh MR600.
+endef
+
+$(eval $(call Profile,MR600))
+
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index e212348509..48893e6aac 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -832,6 +832,7 @@ $(eval $(call SingleProfile,Netgear,$(fs_64k),WNDRMAC,wndrmac,WNDR3700,ttyS0,115
$(eval $(call SingleProfile,Netgear,$(fs_64k),WNDRMACV2,wndrmacv2,WNDR3700,ttyS0,115200,$$(wndr3700v2_mtdlayout),3701,WNDRMACv2,"",-H 29763654+16+128))
$(eval $(call SingleProfile,OpenMesh,$(fs_squash),OM2P,om2p,,,,OM2P))
+$(eval $(call SingleProfile,OpenMesh,$(fs_squash),MR600,mr600,,,,MR600))
$(eval $(call SingleProfile,PB4X,$(fs_128k),ALL0305,all0305,ALL0305,ttyS0,115200))
$(eval $(call SingleProfile,PB4X,$(fs_128k),EAP7660D,eap7660d,EAP7660D,ttyS0,115200))