aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-08-06 19:43:45 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-08-06 19:43:45 +0000
commit277bab74402296d0ad592684f073df0af2df84f8 (patch)
tree0103c70424e54cf1128fd55cd9be8eec022a0c2f
parente1c828122006d68588aeccde8968a115320c8ef6 (diff)
downloadupstream-277bab74402296d0ad592684f073df0af2df84f8.tar.gz
upstream-277bab74402296d0ad592684f073df0af2df84f8.tar.bz2
upstream-277bab74402296d0ad592684f073df0af2df84f8.zip
Allow rdc-2.6 to kexec
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8359 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/kexec-tools/Makefile4
-rw-r--r--target/linux/rdc-2.6/config/default1
2 files changed, 3 insertions, 2 deletions
diff --git a/package/kexec-tools/Makefile b/package/kexec-tools/Makefile
index cfca8b1dcc..7289930812 100644
--- a/package/kexec-tools/Makefile
+++ b/package/kexec-tools/Makefile
@@ -21,7 +21,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/kexec-tools
SECTION:=utils
CATEGORY:=Utilities
- DEPENDS:=@LINUX_2_6_X86 +zlib
+ DEPENDS:=@LINUX_2_6_X86||@LINUX_2_6_RDC +zlib
TITLE:=Kernel boots kernel
DESCRIPTION:=\
kexec is a set of systems call that allows you to load \\\
@@ -32,7 +32,7 @@ endef
MAKE_FLAGS += \
DESTDIR="$(PKG_INSTALL_DIR)" \
EXTRA_CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
- BUILD_CFLAGS="-O2" \
+ BUILD_CFLAGS="-Os" \
LIBS="$(TARGET_LDFLAGS) -lz" \
install
diff --git a/target/linux/rdc-2.6/config/default b/target/linux/rdc-2.6/config/default
index b0990e42e2..ec8a6e6d3d 100644
--- a/target/linux/rdc-2.6/config/default
+++ b/target/linux/rdc-2.6/config/default
@@ -100,6 +100,7 @@ CONFIG_ISA_DMA_API=y
CONFIG_JFFS2_FS_DEBUG=0
CONFIG_JFFS2_RUBIN=y
CONFIG_JFS_FS=m
+CONFIG_KEXEC=y
CONFIG_KTIME_SCALAR=y
# CONFIG_KVM is not set
CONFIG_LBD=y