aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-07-20 01:54:16 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-07-20 01:54:16 +0000
commit211bacfc879c4cb732812e7bda1552114db8e50f (patch)
tree11645ea4436cf775d4ac1240f279d8433a00ac1b
parent7a9d13a75037c0cccec71873c453c5fb822926f8 (diff)
downloadupstream-211bacfc879c4cb732812e7bda1552114db8e50f.tar.gz
upstream-211bacfc879c4cb732812e7bda1552114db8e50f.tar.bz2
upstream-211bacfc879c4cb732812e7bda1552114db8e50f.zip
move the crda dependency to the kmod-cfg80211 package, get rid of crda's dependency on mac80211. this fixes circular dependency issues
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22304 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/crda/Makefile2
-rw-r--r--package/hostapd/Makefile2
-rw-r--r--package/mac80211/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/package/crda/Makefile b/package/crda/Makefile
index 7036dcfd6f..9e9be188ff 100644
--- a/package/crda/Makefile
+++ b/package/crda/Makefile
@@ -28,7 +28,7 @@ define Package/crda
SECTION:=net
CATEGORY:=Network
TITLE:=Central Regulatory Domain Agent (CRDA)
- DEPENDS:=+kmod-mac80211 +libnl-tiny
+ DEPENDS:=+libnl-tiny
URL:=http://wireless.kernel.org/en/developers/Regulatory/CRDA
endef
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index 3e4864dcc0..5bcaba9458 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -82,7 +82,7 @@ ifneq ($(LOCAL_TYPE),hostapd)
CONFIG_DRIVER_ROBOSWITCH=$(CONFIG_PACKAGE_kmod-switch)
endif
-DRV_DEPENDS:=+PACKAGE_kmod-mac80211:libnl-tiny +PACKAGE_kmod-mac80211:crda @(!(TARGET_avr32||TARGET_etrax)||BROKEN)
+DRV_DEPENDS:=+PACKAGE_kmod-mac80211:libnl-tiny @(!(TARGET_avr32||TARGET_etrax)||BROKEN)
define Package/hostapd/Default
SECTION:=net
diff --git a/package/mac80211/Makefile b/package/mac80211/Makefile
index 050447d052..03a1a4b0db 100644
--- a/package/mac80211/Makefile
+++ b/package/mac80211/Makefile
@@ -41,7 +41,7 @@ endef
define KernelPackage/cfg80211
$(call KernelPackage/mac80211/Default)
TITLE:=cfg80211 - wireless configuration API
- DEPENDS+= +wireless-tools +iw @!LINUX_2_6_25
+ DEPENDS+= +wireless-tools +iw @!LINUX_2_6_25 +crda
ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.33)),1)
FILES:= \
$(PKG_BUILD_DIR)/compat/compat.ko \