aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-07-01 15:37:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-07-01 15:37:51 +0000
commit1da638576cc1d02deb2ce04c54d73bf1ae262b15 (patch)
tree4196a1e674855ede0f40cc2dfaf6fe2e390863d6
parent2a4d0888c168c2afb58603b447d8302de594c10e (diff)
downloadupstream-1da638576cc1d02deb2ce04c54d73bf1ae262b15.tar.gz
upstream-1da638576cc1d02deb2ce04c54d73bf1ae262b15.tar.bz2
upstream-1da638576cc1d02deb2ce04c54d73bf1ae262b15.zip
libjson-c: rename the libjson binary package to libjson-c, add a new libjson package with the compatibility library (to deal with the rename)
Backport of r37119 git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@37121 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/libjson-c/Makefile27
-rw-r--r--package/libubox/Makefile4
2 files changed, 26 insertions, 5 deletions
diff --git a/package/libjson-c/Makefile b/package/libjson-c/Makefile
index cc82df48fe..3a8a41b515 100644
--- a/package/libjson-c/Makefile
+++ b/package/libjson-c/Makefile
@@ -27,30 +27,51 @@ include $(INCLUDE_DIR)/package.mk
TARGET_CFLAGS += $(FPIC)
-define Package/libjson
+define Package/libjson-c
SECTION:=libs
CATEGORY:=Libraries
TITLE:=javascript object notation
URL:=http://oss.metaparadigm.com/json-c/
endef
-define Package/libjson/description
+define Package/libjson-c/description
This package contains a library for javascript object notation backends.
endef
+define Package/libjson
+ SECTION:=libs
+ CATEGORY:=Libraries
+ DEPENDS:=+libjson-c
+ TITLE:=javascript object notation (compat library)
+ URL:=http://oss.metaparadigm.com/json-c/
+endef
+
+define Package/libjson/description
+ This package contains a compatibility library for packages that have not
+ been adapted to the json-c library rename yet
+endef
+
+
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/json $(1)/usr/include/
$(CP) $(PKG_INSTALL_DIR)/usr/include/json-c $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libjson.{a,so*} $(1)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libjson-c.{a,so*} $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/json-c.pc $(1)/usr/lib/pkgconfig/
endef
-define Package/libjson/install
+define Package/libjson-c/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libjson-c.so.* $(1)/usr/lib/
endef
+define Package/libjson/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libjson.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libjson-c))
$(eval $(call BuildPackage,libjson))
diff --git a/package/libubox/Makefile b/package/libubox/Makefile
index 231a5875bd..5eebc6e183 100644
--- a/package/libubox/Makefile
+++ b/package/libubox/Makefile
@@ -33,13 +33,13 @@ define Package/libblobmsg-json
SECTION:=libs
CATEGORY:=Libraries
TITLE:=blobmsg <-> json conversion library
- DEPENDS:=+libjson +libubox
+ DEPENDS:=+libjson-c +libubox
endef
define Package/jshn
SECTION:=utils
CATEGORY:=Utilities
- DEPENDS:=+libjson
+ DEPENDS:=+libjson-c
TITLE:=JSON SHell Notation
endef