aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-04-19 20:39:02 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-04-19 20:39:02 +0000
commit1c368aad4c632c30bdd8aaa6c5a0ef62d7b4f4e3 (patch)
treefd410f89ec61f03c2edc68ac09de5c075b04c62a
parent2d188a4557eba7535fd710b5f535bf36fb245903 (diff)
downloadupstream-1c368aad4c632c30bdd8aaa6c5a0ef62d7b4f4e3.tar.gz
upstream-1c368aad4c632c30bdd8aaa6c5a0ef62d7b4f4e3.tar.bz2
upstream-1c368aad4c632c30bdd8aaa6c5a0ef62d7b4f4e3.zip
[package] firewall: process custom rules after forwardings and redirects, this actually allows blocking traffic to certain hosts and other rules
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15278 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/firewall/Makefile2
-rwxr-xr-xpackage/firewall/files/uci_firewall.sh4
2 files changed, 3 insertions, 3 deletions
diff --git a/package/firewall/Makefile b/package/firewall/Makefile
index 7aa385511f..dfbef6106d 100644
--- a/package/firewall/Makefile
+++ b/package/firewall/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=firewall
PKG_VERSION:=1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
include $(INCLUDE_DIR)/package.mk
diff --git a/package/firewall/files/uci_firewall.sh b/package/firewall/files/uci_firewall.sh
index f6fa82b9cb..c197003595 100755
--- a/package/firewall/files/uci_firewall.sh
+++ b/package/firewall/files/uci_firewall.sh
@@ -401,12 +401,12 @@ fw_init() {
config_foreach fw_defaults defaults
echo "Loading zones"
config_foreach fw_zone zone
- echo "Loading rules"
- config_foreach fw_rule rule
echo "Loading forwarding"
config_foreach fw_forwarding forwarding
echo "Loading redirects"
config_foreach fw_redirect redirect
+ echo "Loading rules"
+ config_foreach fw_rule rule
echo "Loading includes"
config_foreach fw_include include
uci_set_state firewall core loaded 1