aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-08-22 09:43:18 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-08-22 09:43:18 +0000
commit0f8b30ebfb40401df33a5e86c0b4c425bd89b4fe (patch)
treee795c66f57fa390f0e02581c07a8f0cab21ca940
parent9f3a4fd1bca0948c1b4d54e4ba9a660af99b1e00 (diff)
downloadupstream-0f8b30ebfb40401df33a5e86c0b4c425bd89b4fe.tar.gz
upstream-0f8b30ebfb40401df33a5e86c0b4c425bd89b4fe.tar.bz2
upstream-0f8b30ebfb40401df33a5e86c0b4c425bd89b4fe.zip
ar71xx: add support for TP-Link TL-WDR3600
The TL-WDR3600 is identical to the TL-WDR4300 with the exception that is has only two antennas. [juhosg: remove the custom machine type, change the board name instead] Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33219 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/ar71xx.sh5
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wdr4300.c3
-rw-r--r--target/linux/ar71xx/generic/profiles/tp-link.mk4
-rw-r--r--target/linux/ar71xx/image/Makefile1
-rw-r--r--target/linux/ar71xx/patches-3.3/610-MIPS-ath79-openwrt-machines.patch2
5 files changed, 10 insertions, 5 deletions
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index 648cca8b5a..23d34a3370 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -123,6 +123,9 @@ tplink_board_detect() {
"342000"*)
model="TP-Link TL-MR3420"
;;
+ "360000"*)
+ model="TP-Link TL-WDR3600"
+ ;;
"430000"*)
model="TP-Link TL-WDR4300"
;;
@@ -321,7 +324,7 @@ ar71xx_board_detect() {
*"TL-WA901ND v2")
name="tl-wa901nd-v2"
;;
- *TL-WDR4300)
+ *"TL-WDR3600/4300/4310")
name="tl-wdr4300"
;;
*TL-WR741ND)
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wdr4300.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wdr4300.c
index 6b3b1fe560..331de5680b 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wdr4300.c
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wdr4300.c
@@ -199,5 +199,6 @@ static void __init wdr4300_setup(void)
ath79_register_usb();
}
-MIPS_MACHINE(ATH79_MACH_TL_WDR4300, "TL-WDR4300", "TP-LINK TL-WDR4300",
+MIPS_MACHINE(ATH79_MACH_TL_WDR4300, "TL-WDR4300",
+ "TP-LINK TL-WDR3600/4300/4310",
wdr4300_setup);
diff --git a/target/linux/ar71xx/generic/profiles/tp-link.mk b/target/linux/ar71xx/generic/profiles/tp-link.mk
index 74355e83b8..056a91703d 100644
--- a/target/linux/ar71xx/generic/profiles/tp-link.mk
+++ b/target/linux/ar71xx/generic/profiles/tp-link.mk
@@ -95,12 +95,12 @@ $(eval $(call Profile,TLWA901))
define Profile/TLWDR4300
- NAME:=TP-LINK TL-WDR4300/ TL-WDR4310
+ NAME:=TP-LINK TL-WDR3600/4300/4310
PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
endef
define Profile/TLWDR4300/Description
- Package set optimized for the TP-LINK TL-WDR4300.
+ Package set optimized for the TP-LINK TL-WDR3600/4300/4310.
endef
$(eval $(call Profile,TLWDR4300))
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 26ac0ab102..43bb9d320c 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -991,6 +991,7 @@ endef
tlwdr4300_cmdline=board=TL-WDR4300 console=ttyS0,115200
define Image/Build/Profile/TLWDR4300
+ $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK-LZMA,tl-wdr3600-v1,$(tlwdr4300_cmdline),0x36000001,1,8Mlzma)
$(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK-LZMA,tl-wdr4300-v1,$(tlwdr4300_cmdline),0x43000001,1,8Mlzma)
$(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK-LZMA,tl-wdr4310-v1,$(tlwdr4300_cmdline),0x43100001,1,8Mlzma)
endef
diff --git a/target/linux/ar71xx/patches-3.3/610-MIPS-ath79-openwrt-machines.patch b/target/linux/ar71xx/patches-3.3/610-MIPS-ath79-openwrt-machines.patch
index 4179681a29..73db5e44df 100644
--- a/target/linux/ar71xx/patches-3.3/610-MIPS-ath79-openwrt-machines.patch
+++ b/target/linux/ar71xx/patches-3.3/610-MIPS-ath79-openwrt-machines.patch
@@ -495,7 +495,7 @@
+ select ATH79_DEV_WMAC
+
+config ATH79_MACH_TL_WDR4300
-+ bool "TP-LINK TL-WDR4300 board support"
++ bool "TP-LINK TL-WDR3600/4300/4310 board support"
+ select SOC_AR934X
+ select ATH79_DEV_AP9X_PCI if PCI
+ select ATH79_DEV_ETH