aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-11-12 13:42:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-11-12 13:42:07 +0000
commit0f822c3de4609b0001fbfbade23f1877a4774f03 (patch)
treeea571bd4c5c76bac9d76e85a029f85fbf75ae89d
parent602b676769ee249cbe2cdcb065830edda2b34003 (diff)
downloadupstream-0f822c3de4609b0001fbfbade23f1877a4774f03.tar.gz
upstream-0f822c3de4609b0001fbfbade23f1877a4774f03.tar.bz2
upstream-0f822c3de4609b0001fbfbade23f1877a4774f03.zip
gcc: add a config option for using the gcc graphite framework (disabled by default)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18403 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--toolchain/gcc/Config.in5
-rw-r--r--toolchain/gcc/Makefile2
-rw-r--r--tools/Makefile4
3 files changed, 8 insertions, 3 deletions
diff --git a/toolchain/gcc/Config.in b/toolchain/gcc/Config.in
index 6df2661737..b19427be0a 100644
--- a/toolchain/gcc/Config.in
+++ b/toolchain/gcc/Config.in
@@ -50,6 +50,11 @@ endif
endchoice
+config GCC_USE_GRAPHITE
+ bool
+ prompt "Compile in support for the new Graphite framework in GCC 4.4+" if TOOLCHAINOPTS
+ depends GCC_VERSION_4_4_1 || GCC_VERSION_4_4_2
+
config EXTRA_GCC_CONFIG_OPTIONS
string
prompt "Additional gcc configure options" if TOOLCHAINOPTS
diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index 9d865e94d3..ea103c4539 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -90,7 +90,7 @@ GCC_CONFIGURE:= \
--disable-libmudflap \
--disable-multilib \
--disable-nls \
- $(if $(CONFIG_GCC_VERSION_4_4),--with-host-libstdcxx=-lstdc++) \
+ $(if $(CONFIG_GCC_USE_GRAPHITE),--with-host-libstdcxx=-lstdc++) \
$(SOFT_FLOAT_CONFIG_OPTION) \
$(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
$(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 --with-abi=64) \
diff --git a/tools/Makefile b/tools/Makefile
index 6e5eb24cd3..b7c7f43db6 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -20,7 +20,7 @@ tools-y += firmware-utils patch-cmdline quilt yaffs2
tools-$(CONFIG_CCACHE) += ccache
tools-dep += lzma
-ifdef CONFIG_GCC_VERSION_4_4
+ifdef CONFIG_GCC_USE_GRAPHITE
tools-y += ppl cloog
$(curdir)/cloog/compile := $(curdir)/ppl/install
endif
@@ -82,5 +82,5 @@ $(curdir)//compile = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/.prepared $($(
$(curdir)/ := .config prereq
$(curdir)//install = $(1)/compile
-$(eval $(call stampfile,$(curdir),tools,install,,CONFIG_CCACHE CONFIG_powerpc CONFIG_GCC_VERSION_4_3))
+$(eval $(call stampfile,$(curdir),tools,install,,CONFIG_CCACHE CONFIG_powerpc CONFIG_GCC_VERSION_4_3 CONFIG_GCC_USE_GRAPHITE))
$(eval $(call subdir,$(curdir)))