aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-02-16 18:28:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-02-16 18:28:55 +0000
commit0dda72e58d2e088a65321b6984125f7dea953451 (patch)
tree66f85a47b0067d482f84fabdddd743c46c02c117
parent7257c1cad9eb06858bc84efd47d27c6e0d75afd1 (diff)
downloadupstream-0dda72e58d2e088a65321b6984125f7dea953451.tar.gz
upstream-0dda72e58d2e088a65321b6984125f7dea953451.tar.bz2
upstream-0dda72e58d2e088a65321b6984125f7dea953451.zip
kernel: add a package for block2mtd
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19665 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/kernel/modules/other.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 47fee9f53c..ada8365a7f 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -7,6 +7,14 @@
OTHER_MENU:=Other modules
+define KernelPackage/block2mtd
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Block device MTD emulation
+ KCONFIG:=CONFIG_MTD_BLOCK2MTD
+ FILES:=$(LINUX_DIR)/drivers/mtd/devices/block2mtd.$(LINUX_KMOD_SUFFIX)
+endef
+$(eval $(call KernelPackage,block2mtd))
+
define KernelPackage/crc-itu-t
SUBMENU:=$(OTHER_MENU)
TITLE:=CRC ITU-T V.41 support