aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2009-04-20 12:27:34 +0000
committerHamish Guthrie <hcg@openwrt.org>2009-04-20 12:27:34 +0000
commit06ac872ec99892224ece08406ece889aea2b5fc6 (patch)
tree96a4f97eb21a826bf4a8a500b0815de79ffe045c
parentfb326d5683274a13463269281a954916426ee9eb (diff)
downloadupstream-06ac872ec99892224ece08406ece889aea2b5fc6.tar.gz
upstream-06ac872ec99892224ece08406ece889aea2b5fc6.tar.bz2
upstream-06ac872ec99892224ece08406ece889aea2b5fc6.zip
[kernel package bluetooth] add hidp support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15293 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/kernel/modules/other.mk7
1 files changed, 5 insertions, 2 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 60b6e037b8..69f0cb7e5f 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -243,13 +243,15 @@ define KernelPackage/bluetooth
CONFIG_BLUEZ_BNEP \
CONFIG_BLUEZ_HCIUART \
CONFIG_BLUEZ_HCIUSB \
+ CONFIG_BLUEZ_HIDP \
CONFIG_BT \
CONFIG_BT_L2CAP \
CONFIG_BT_SCO \
CONFIG_BT_RFCOMM \
CONFIG_BT_BNEP \
CONFIG_BT_HCIUSB \
- CONFIG_BT_HCIUART
+ CONFIG_BT_HCIUART \
+ CONFIG_BT_HIDP
endef
define KernelPackage/bluetooth/2.4
@@ -287,9 +289,10 @@ define KernelPackage/bluetooth/2.6
$(LINUX_DIR)/net/bluetooth/sco.$(LINUX_KMOD_SUFFIX) \
$(LINUX_DIR)/net/bluetooth/rfcomm/rfcomm.$(LINUX_KMOD_SUFFIX) \
$(LINUX_DIR)/net/bluetooth/bnep/bnep.$(LINUX_KMOD_SUFFIX) \
+ $(LINUX_DIR)/net/bluetooth/hidp/hidp.$(LINUX_KMOD_SUFFIX) \
$(LINUX_DIR)/drivers/bluetooth/hci_uart.$(LINUX_KMOD_SUFFIX) \
$(LINUX_DIR)/drivers/bluetooth/hci_usb.$(LINUX_KMOD_SUFFIX)
- AUTOLOAD:=$(call AutoLoad,90,bluetooth l2cap sco rfcomm bnep hci_uart hci_usb)
+ AUTOLOAD:=$(call AutoLoad,90,bluetooth l2cap sco rfcomm bnep hidp hci_uart hci_usb)
endef
define KernelPackage/bluetooth/description