aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/uclibc++/patches/002-path_to_bash.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/libs/uclibc++/patches/002-path_to_bash.patch')
-rw-r--r--package/libs/uclibc++/patches/002-path_to_bash.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/libs/uclibc++/patches/002-path_to_bash.patch b/package/libs/uclibc++/patches/002-path_to_bash.patch
new file mode 100644
index 0000000..26d88ee
--- /dev/null
+++ b/package/libs/uclibc++/patches/002-path_to_bash.patch
@@ -0,0 +1,11 @@
+--- a/bin/Makefile
++++ b/bin/Makefile
+@@ -13,7 +13,7 @@ install:
+ $(INSTALL) -m 755 $(WRAPPER) $(PREFIX)$(UCLIBCXX_RUNTIME_BINDIR)
+
+ $(WRAPPER): Makefile
+- echo '#!/bin/sh' > $@
++ echo '#!/usr/bin/env bash' > $@
+ echo '' >> $@
+ echo 'WRAPPER_INCLUDEDIR="$${WRAPPER_INCLUDEDIR:=-I$(UCLIBCXX_RUNTIME_INCLUDEDIR)}"' >> $@
+ echo 'WRAPPER_LIBDIR="$${WRAPPER_LIBDIR:=-L$(UCLIBCXX_RUNTIME_LIBDIR)}"' >> $@