aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/kexec-tools/patches/0002-configure.ac-apply-necessary-quotes-to-result-of-mac.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/kexec-tools/patches/0002-configure.ac-apply-necessary-quotes-to-result-of-mac.patch')
-rw-r--r--package/boot/kexec-tools/patches/0002-configure.ac-apply-necessary-quotes-to-result-of-mac.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/package/boot/kexec-tools/patches/0002-configure.ac-apply-necessary-quotes-to-result-of-mac.patch b/package/boot/kexec-tools/patches/0002-configure.ac-apply-necessary-quotes-to-result-of-mac.patch
new file mode 100644
index 0000000..aba8af7
--- /dev/null
+++ b/package/boot/kexec-tools/patches/0002-configure.ac-apply-necessary-quotes-to-result-of-mac.patch
@@ -0,0 +1,52 @@
+From eb20884c9bbc42bdf1ccace4444f3ce72657d7d8 Mon Sep 17 00:00:00 2001
+From: Yousong Zhou <yszhou4tech@gmail.com>
+Date: Tue, 9 Sep 2014 20:15:16 +0800
+Subject: [PATCH 2/5] configure.ac: apply necessary quotes to result of macro
+ expansion.
+
+This can fix the following error when searching for lzma support and
+while at it also apply the practice to other uses of the same pattern.
+
+ checking for lzma_code in -llzma... ./configure: line 4756: ac_fn_c_try_link: command not found
+
+Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
+---
+ configure.ac | 12 ++++++------
+ 1 file changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index db93331..c410e90 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -152,22 +152,22 @@ AC_CHECK_PROG([DIRNAME], dirname, dirname, "no", [$PATH])
+ dnl See if I have a usable copy of zlib available
+ if test "$with_zlib" = yes ; then
+ AC_CHECK_HEADER(zlib.h,
+- AC_CHECK_LIB(z, inflateInit_, ,
+- AC_MSG_NOTICE([zlib support disabled])))
++ [AC_CHECK_LIB(z, inflateInit_, ,
++ AC_MSG_NOTICE([zlib support disabled]))])
+ fi
+
+ dnl See if I have a usable copy of lzma available
+ if test "$with_lzma" = yes ; then
+ AC_CHECK_HEADER(lzma.h,
+- AC_CHECK_LIB(lzma, lzma_code, ,
+- AC_MSG_NOTICE([lzma support disabled])))
++ [AC_CHECK_LIB(lzma, lzma_code, ,
++ AC_MSG_NOTICE([lzma support disabled]))])
+ fi
+
+ dnl find Xen control stack libraries
+ if test "$with_xen" = yes ; then
+ AC_CHECK_HEADER(xenctrl.h,
+- AC_CHECK_LIB(xenctrl, xc_kexec_load, ,
+- AC_MSG_NOTICE([Xen support disabled])))
++ [AC_CHECK_LIB(xenctrl, xc_kexec_load, ,
++ AC_MSG_NOTICE([Xen support disabled]))])
+ fi
+
+ dnl ---Sanity checks
+--
+1.7.10.4
+