aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/router_le/profiles/Compex.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/adm5120/router_le/profiles/Compex.mk')
-rw-r--r--target/linux/adm5120/router_le/profiles/Compex.mk37
1 files changed, 37 insertions, 0 deletions
diff --git a/target/linux/adm5120/router_le/profiles/Compex.mk b/target/linux/adm5120/router_le/profiles/Compex.mk
new file mode 100644
index 0000000..79d1f3f
--- /dev/null
+++ b/target/linux/adm5120/router_le/profiles/Compex.mk
@@ -0,0 +1,37 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/NP27G
+ NAME:=Compex NP27G
+ PACKAGES:=kmod-ath5k kmod-usb-core kmod-usb-adm5120
+endef
+
+define Profile/NP27G/Description
+ Package set optimized for the Compex NP27G.
+endef
+
+define Profile/NP28G
+ NAME:=Compex NP28G
+ PACKAGES:=kmod-ath5k kmod-usb-core kmod-usb-uhci kmod-usb2
+endef
+
+define Profile/NP28G/Description
+ Package set optimized for the Compex NP28G.
+endef
+
+define Profile/WP54
+ NAME:=Compex WP54 family
+ PACKAGES:=kmod-ath5k
+endef
+
+define Profile/WP54/Description
+ Package set optimized for the Compex WP54 family.
+endef
+
+$(eval $(call Profile,NP27G))
+$(eval $(call Profile,NP28G))
+$(eval $(call Profile,WP54))