aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/001-depends.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/001-depends.mk')
-rw-r--r--package/kernel/linux/modules/001-depends.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/001-depends.mk b/package/kernel/linux/modules/001-depends.mk
new file mode 100644
index 0000000..806c3dc
--- /dev/null
+++ b/package/kernel/linux/modules/001-depends.mk
@@ -0,0 +1,14 @@
+#
+# Copyright (C) 2010-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define AddDepends/nls
+ DEPENDS+= +kmod-nls-base $(foreach cp,$(1),+kmod-nls-$(cp))
+endef
+
+define AddDepends/rfkill
+ DEPENDS+= +USE_RFKILL:kmod-rfkill $(1)
+endef