aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-envtools/patches/001-compile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/uboot-envtools/patches/001-compile.patch')
-rw-r--r--package/boot/uboot-envtools/patches/001-compile.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/package/boot/uboot-envtools/patches/001-compile.patch b/package/boot/uboot-envtools/patches/001-compile.patch
new file mode 100644
index 0000000..1705979
--- /dev/null
+++ b/package/boot/uboot-envtools/patches/001-compile.patch
@@ -0,0 +1,13 @@
+--- a/tools/env/Makefile
++++ b/tools/env/Makefile
+@@ -10,6 +10,10 @@
+ # with "CC" here for the maximum code reuse of scripts/Makefile.host.
+ HOSTCC = $(CC)
+
++ifneq ($(TARGET_CFLAGS),)
++HOSTCFLAGS = $(TARGET_CFLAGS)
++endif
++
+ # Compile for a hosted environment on the target
+ HOST_EXTRACFLAGS = $(patsubst -I%,-idirafter%, $(filter -I%, $(UBOOTINCLUDE))) \
+ -idirafter $(srctree)/tools/env \