aboutsummaryrefslogtreecommitdiffstats
path: root/include/scons.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/scons.mk')
-rw-r--r--include/scons.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/include/scons.mk b/include/scons.mk
new file mode 100644
index 0000000..a8306b6
--- /dev/null
+++ b/include/scons.mk
@@ -0,0 +1,23 @@
+export PLATFORM=posix
+
+SCONS_VARS = \
+ CC="$(TARGET_CC_NOCACHE)" \
+ CXX="$(TARGET_CXX_NOCACHE)" \
+ CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)" \
+ CXXFLAGS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)" \
+ CPPFLAGS="$(TARGET_CPPFLAGS) $(EXTRA_CPPFLAGS)" \
+ LDFLAGS="$(TARGET_LDFLAGS) $(EXTRA_LDFLAGS)" \
+ DESTDIR="$(PKG_INSTALL_DIR)"
+
+define Build/Configure/Default
+ (cd $(PKG_BUILD_DIR); \
+ $(SCONS_VARS) \
+ scons \
+ prefix=/usr \
+ $(SCONS_OPTIONS) \
+ install \
+ )
+endef
+
+define Build/Compile
+endef