aboutsummaryrefslogtreecommitdiffstats
path: root/include/package-seccomp.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/package-seccomp.mk')
-rw-r--r--include/package-seccomp.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/include/package-seccomp.mk b/include/package-seccomp.mk
new file mode 100644
index 0000000..fa49617
--- /dev/null
+++ b/include/package-seccomp.mk
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+PKG_CONFIG_DEPENDS+= CONFIG_KERNEL_SECCOMP
+
+ifeq ($(CONFIG_KERNEL_SECCOMP),y)
+ define InstallSeccomp
+ $(INSTALL_DIR) $(1)/etc/seccomp
+ $(INSTALL_DATA) $(2) $(1)/etc/seccomp/
+ endef
+endif