summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames <31272717+gpd-pocket-hacker@users.noreply.github.com>2021-03-16 20:10:04 +0000
committerJames <31272717+gpd-pocket-hacker@users.noreply.github.com>2021-03-16 20:10:04 +0000
commit2a4461e2089a9fcfa089f07e74a9b18435e7b52d (patch)
treef8d726d6495edf49341a7c4c5520902848a71426
parentc495867b36e75b0cc8f1f423abcb973cac95cc1c (diff)
downloadmaster-d20f4fc-pq-2a4461e2089a9fcfa089f07e74a9b18435e7b52d.tar.gz
master-d20f4fc-pq-2a4461e2089a9fcfa089f07e74a9b18435e7b52d.tar.bz2
master-d20f4fc-pq-2a4461e2089a9fcfa089f07e74a9b18435e7b52d.zip
syncing to other houseHEADmaster
-rw-r--r--master/endstop106
1 files changed, 106 insertions, 0 deletions
diff --git a/master/endstop b/master/endstop
index e69de29..ab633d8 100644
--- a/master/endstop
+++ b/master/endstop
@@ -0,0 +1,106 @@
+diff --git a/.config b/.config
+index c316295..330d64e 100644
+--- a/.config
++++ b/.config
+@@ -2746,8 +2746,10 @@ CONFIG_PACKAGE_python-pydoc=m
+ # CONFIG_PACKAGE_python-pyopenssl-src is not set
+ # CONFIG_PACKAGE_python-pyptlib is not set
+ # CONFIG_PACKAGE_python-pyptlib-src is not set
+-# CONFIG_PACKAGE_python-pyserial is not set
++CONFIG_PACKAGE_python-pyserial=m
+ # CONFIG_PACKAGE_python-pyserial-src is not set
++CONFIG_PACKAGE_python-pyusb=m
++# CONFIG_PACKAGE_python-pyusb-src is not set
+ # CONFIG_PACKAGE_python-qrcode is not set
+ # CONFIG_PACKAGE_python-requests is not set
+ # CONFIG_PACKAGE_python-requests-oauthlib is not set
+@@ -2863,6 +2865,8 @@ CONFIG_PACKAGE_python3-pydoc=m
+ # CONFIG_PACKAGE_python3-pyopenssl-src is not set
+ # CONFIG_PACKAGE_python3-pyserial is not set
+ # CONFIG_PACKAGE_python3-pyserial-src is not set
++CONFIG_PACKAGE_python3-pyusb=m
++# CONFIG_PACKAGE_python3-pyusb-src is not set
+ # CONFIG_PACKAGE_python3-service-identity is not set
+ # CONFIG_PACKAGE_python3-service-identity-src is not set
+ # CONFIG_PACKAGE_python3-setuptools is not set
+@@ -5130,7 +5134,7 @@ CONFIG_PACKAGE_coreutils-sha512sum=m
+ CONFIG_PACKAGE_dbus=m
+ # CONFIG_PACKAGE_dbus-utils is not set
+ # CONFIG_PACKAGE_device-observatory is not set
+-# CONFIG_PACKAGE_dfu-util is not set
++CONFIG_PACKAGE_dfu-util=m
+ CONFIG_PACKAGE_digitemp=m
+ CONFIG_PACKAGE_digitemp-usb=m
+ # CONFIG_PACKAGE_dmesg is not set
+diff --git a/package/jmm/python-pyusb/Makefile b/package/jmm/python-pyusb/Makefile
+new file mode 100644
+index 0000000..9e68910
+--- /dev/null
++++ b/package/jmm/python-pyusb/Makefile
+@@ -0,0 +1,66 @@
++#
++# Copyright (C) 2015 OpenWrt.org
++#
++# This is free software, licensed under the GNU General Public License v2.
++# See /LICENSE for more information.
++#
++
++include $(TOPDIR)/rules.mk
++
++PKG_NAME:=python-pyusb
++PKG_VERSION:=1.1.1
++PKG_RELEASE:=1
++
++PKG_SOURCE:=pyusb-$(PKG_VERSION).tar.gz
++PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/b9/8d/25c4e446a07e918eb39b5af25c4a83a89db95ae44e4ed5a46c3c53b0a4d6/
++PKG_HASH:=7d449ad916ce58aff60b89aae0b65ac130f289c24d6a5b7b317742eccffafc38
++
++PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-pyusb-$(PKG_VERSION)
++
++PKG_LICENSE:=BSD
++PKG_MAINTAINER:=Micke Prag <micke.prag@telldus.se>
++
++include $(INCLUDE_DIR)/package.mk
++include ../../feeds/packages/python/../python-package.mk
++include ../../feeds/packages/python3/../python3-package.mk
++
++PKG_UNPACK:=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
++
++define Package/python-pyusb/Default
++ SECTION:=lang-python
++ CATEGORY:=Languages
++ SUBMENU:=Python
++ URL:=https://pyusb.github.io/pyusb/
++endef
++
++define Package/python-pyusb
++$(call Package/python-pyusb/Default)
++ TITLE:=python-pyusb
++ DEPENDS:=+python-light +libusb-1.0
++ VARIANT:=python
++endef
++
++define Package/python3-pyusb
++$(call Package/python-pyusb/Default)
++ TITLE:=python3-pyusb
++ DEPENDS:=+python3-light +libusb-1.0
++ VARIANT:=python3
++endef
++
++define Package/python-pyusb/description
++meh
++endef
++
++define Package/python3-pyusb/description
++$(call Package/python-pyusb/description)
++.
++(Variant for Python3)
++endef
++
++$(eval $(call PyPackage,python-pyusb))
++$(eval $(call BuildPackage,python-pyusb))
++$(eval $(call BuildPackage,python-pyusb-src))
++
++$(eval $(call Py3Package,python3-pyusb))
++$(eval $(call BuildPackage,python3-pyusb))
++$(eval $(call BuildPackage,python3-pyusb-src))