From f82831818b0a3035c1ebfc512bd86069efbeef5c Mon Sep 17 00:00:00 2001
From: Ash Benz <ash.benz@bk.ru>
Date: Fri, 24 Jun 2016 08:14:33 +0200
Subject: fw-utils/tplink-safeloader.c: Add support for Archer C2600

Signed-off-by: Ash Benz <ash.benz@bk.ru>
---
 tools/firmware-utils/src/tplink-safeloader.c | 114 ++++++++++++++++++++++++++-
 1 file changed, 111 insertions(+), 3 deletions(-)

(limited to 'tools')

diff --git a/tools/firmware-utils/src/tplink-safeloader.c b/tools/firmware-utils/src/tplink-safeloader.c
index 77a894b237..2e204aa233 100644
--- a/tools/firmware-utils/src/tplink-safeloader.c
+++ b/tools/firmware-utils/src/tplink-safeloader.c
@@ -105,6 +105,8 @@ static const uint8_t md5_salt[16] = {
 /** Vendor information for CPE210/220/510/520 */
 static const char cpe510_vendor[] = "CPE510(TP-LINK|UN|N300-5):1.0\r\n";
 
+/** Vendor information for C2600 */
+static const char c2600_vendor[] = "";
 
 /**
     The flash partition table for CPE210/220/510/520;
@@ -127,6 +129,39 @@ static const struct flash_partition_entry cpe510_partitions[] = {
 	{NULL, 0, 0}
 };
 
+/**
+    The flash partition table for C2600;
+    it is the same as the one used by the stock images.
+*/
+static const struct flash_partition_entry c2600_partitions[] = {
+        {"SBL1", 0x00000, 0x20000},
+        {"MIBIB", 0x20000, 0x20000},
+        {"SBL2", 0x40000, 0x20000},
+        {"SBL3", 0x60000, 0x30000},
+        {"DDRCONFIG", 0x90000, 0x10000},
+        {"SSD", 0xa0000, 0x10000},
+        {"TZ", 0xb0000, 0x30000},
+        {"RPM", 0xe0000, 0x20000},
+        {"fs-uboot", 0x100000, 0x70000},
+        {"uboot-env", 0x170000, 0x40000},
+        {"radio", 0x1b0000, 0x40000},
+        {"os-image", 0x1f0000, 0x200000},
+        {"file-system", 0x3f0000, 0x1b00000},
+        {"default-mac", 0x1ef0000, 0x00200},
+        {"pin", 0x1ef0200, 0x00200},
+        {"product-info", 0x1ef0400, 0x0fc00},
+        {"partition-table", 0x1f00000, 0x10000},
+        {"soft-version", 0x1f10000, 0x10000},
+        {"support-list", 0x1f20000, 0x10000},
+        {"profile", 0x1f30000, 0x10000},
+        {"default-config", 0x1f40000, 0x10000},
+        {"user-config", 0x1f50000, 0x40000},
+        {"qos-db", 0x1f90000, 0x40000},
+        {"usb-config", 0x1fd0000, 0x10000},
+        {"log", 0x1fe0000, 0x20000},
+	{NULL, 0, 0}
+};
+
 /**
    The support list for CPE210/220/510/520
 */
@@ -141,6 +176,13 @@ static const char cpe510_support_list[] =
 	"CPE220(TP-LINK|UN|N300-2):1.0\r\n"
 	"CPE220(TP-LINK|UN|N300-2):1.1\r\n";
 
+/**
+   The support list for C2600
+*/
+static const char c2600_support_list[] =
+	"SupportList:\r\n"
+	"{product_name:Archer C2600,product_ver:1.0.0,special_id:00000000}\r\n";
+
 #define error(_ret, _errno, _str, ...)				\
 	do {							\
 		fprintf(stderr, _str ": %s\n", ## __VA_ARGS__,	\
@@ -240,14 +282,14 @@ static struct image_partition_entry make_soft_version(uint32_t rev) {
 }
 
 /** Generates the support-list partition */
-static struct image_partition_entry make_support_list(const char *support_list) {
+static struct image_partition_entry make_support_list(const char *support_list, bool trailzero) {
 	size_t len = strlen(support_list);
 	struct image_partition_entry entry = alloc_image_partition("support-list", len + 9);
 
 	put32(entry.data, len);
 	memset(entry.data+4, 0, 4);
 	memcpy(entry.data+8, support_list, len);
-	entry.data[len+8] = '\xff';
+	entry.data[len+8] = trailzero ? '\x00' : '\xff';
 
 	return entry;
 }
@@ -436,6 +478,37 @@ static void * generate_sysupgrade_image(const struct flash_partition_entry *flas
 	return image;
 }
 
+static void * generate_sysupgrade_image_c2600(const struct flash_partition_entry *flash_parts, const struct image_partition_entry *image_parts, size_t *len) {
+	const struct flash_partition_entry *flash_os_image = &flash_parts[11];
+	const struct flash_partition_entry *flash_file_system = &flash_parts[12];
+
+	const struct image_partition_entry *image_os_image = &image_parts[3];
+	const struct image_partition_entry *image_file_system = &image_parts[4];
+
+	assert(strcmp(flash_os_image->name, "os-image") == 0);
+	assert(strcmp(flash_file_system->name, "file-system") == 0);
+
+	assert(strcmp(image_os_image->name, "os-image") == 0);
+	assert(strcmp(image_file_system->name, "file-system") == 0);
+
+	if (image_os_image->size > flash_os_image->size)
+		error(1, 0, "kernel image too big (more than %u bytes)", (unsigned)flash_os_image->size);
+	if (image_file_system->size > flash_file_system->size)
+		error(1, 0, "rootfs image too big (more than %u bytes)", (unsigned)flash_file_system->size);
+
+	*len = flash_file_system->base - flash_os_image->base + image_file_system->size;
+
+	uint8_t *image = malloc(*len);
+	if (!image)
+		error(1, errno, "malloc");
+
+	memset(image, 0xff, *len);
+
+	memcpy(image, image_os_image->data, image_os_image->size);
+	memcpy(image + flash_file_system->base - flash_os_image->base, image_file_system->data, image_file_system->size);
+
+	return image;
+}
 
 /** Generates an image for CPE210/220/510/520 and writes it to a file */
 static void do_cpe510(const char *output, const char *kernel_image, const char *rootfs_image, uint32_t rev, bool add_jffs2_eof, bool sysupgrade) {
@@ -443,7 +516,7 @@ static void do_cpe510(const char *output, const char *kernel_image, const char *
 
 	parts[0] = make_partition_table(cpe510_partitions);
 	parts[1] = make_soft_version(rev);
-	parts[2] = make_support_list(cpe510_support_list);
+	parts[2] = make_support_list(cpe510_support_list,false);
 	parts[3] = read_file("os-image", kernel_image, false);
 	parts[4] = read_file("file-system", rootfs_image, add_jffs2_eof);
 
@@ -470,6 +543,39 @@ static void do_cpe510(const char *output, const char *kernel_image, const char *
 		free_image_partition(parts[i]);
 }
 
+/** Generates an image for C2600 and writes it to a file */
+static void do_c2600(const char *output, const char *kernel_image, const char *rootfs_image, uint32_t rev, bool add_jffs2_eof, bool sysupgrade) {
+	struct image_partition_entry parts[6] = {};
+
+	parts[0] = make_partition_table(c2600_partitions);
+	parts[1] = make_soft_version(rev);
+	parts[2] = make_support_list(c2600_support_list,true);
+	parts[3] = read_file("os-image", kernel_image, false);
+	parts[4] = read_file("file-system", rootfs_image, add_jffs2_eof);
+
+	size_t len;
+	void *image;
+	if (sysupgrade)
+		image = generate_sysupgrade_image_c2600(c2600_partitions, parts, &len);
+	else
+		image = generate_factory_image(c2600_vendor, parts, &len);
+
+	FILE *file = fopen(output, "wb");
+	if (!file)
+		error(1, errno, "unable to open output file");
+
+	if (fwrite(image, len, 1, file) != 1)
+		error(1, 0, "unable to write output file");
+
+	fclose(file);
+
+	free(image);
+
+	size_t i;
+	for (i = 0; parts[i].name; i++)
+		free_image_partition(parts[i]);
+}
+
 
 /** Usage output */
 static void usage(const char *argv0) {
@@ -552,6 +658,8 @@ int main(int argc, char *argv[]) {
 
 	if (strcmp(board, "CPE510") == 0)
 		do_cpe510(output, kernel_image, rootfs_image, rev, add_jffs2_eof, sysupgrade);
+	else if (strcmp(board, "C2600") == 0)
+		do_c2600(output, kernel_image, rootfs_image, rev, add_jffs2_eof, sysupgrade);
 	else
 		error(1, 0, "unsupported board %s", board);
 
-- 
cgit v1.2.3


From dafbd7fdb872572911269dcec85e736d4c3723d0 Mon Sep 17 00:00:00 2001
From: Henryk Heisig <hyniu@o2.pl>
Date: Fri, 24 Jun 2016 13:38:58 +0200
Subject: tools/firmware-utils: Add Archer C50 to mktplinkfw2

Signed-off-by: Henryk Heisig <hyniu@o2.pl>
---
 tools/firmware-utils/src/mktplinkfw2.c | 7 +++++++
 1 file changed, 7 insertions(+)

(limited to 'tools')

diff --git a/tools/firmware-utils/src/mktplinkfw2.c b/tools/firmware-utils/src/mktplinkfw2.c
index 9b9ebf526c..213e6729a4 100644
--- a/tools/firmware-utils/src/mktplinkfw2.c
+++ b/tools/firmware-utils/src/mktplinkfw2.c
@@ -184,6 +184,13 @@ static struct board_info boards[] = {
 		.hw_rev		= 0x2f,
 		.layout_id	= "16Mltq",
 		.hdr_ver	= 2,
+	}, {
+		.id		= "ArcherC50",
+		.hw_id		= 0xc7500001,
+		.hw_rev		= 69,
+		.layout_id	= "8Mmtk",
+		.hdr_ver	= 3,
+		.endian_swap	= true,
 	}, {
 		/* terminating entry */
 	}
-- 
cgit v1.2.3


From 6d23a930b40474d5524d9705ea71016714d6be91 Mon Sep 17 00:00:00 2001
From: Kevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>
Date: Fri, 24 Jun 2016 14:02:15 +0200
Subject: tools: e2fsprogs: bump to 1.43.1

Bump e2fsprogs to v1.43.1 & refresh patches

Signed-off-by: Kevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>
---
 tools/e2fsprogs/Makefile                              |  5 +++--
 tools/e2fsprogs/patches/002-dont-build-e4defrag.patch |  2 +-
 tools/e2fsprogs/patches/003-openbsd-compat.patch      | 12 +-----------
 tools/e2fsprogs/patches/004-freebsd-compat.patch      |  2 +-
 tools/e2fsprogs/patches/005-darwin-compat.patch       |  1 -
 5 files changed, 6 insertions(+), 16 deletions(-)

(limited to 'tools')

diff --git a/tools/e2fsprogs/Makefile b/tools/e2fsprogs/Makefile
index e102759925..1251361b3e 100644
--- a/tools/e2fsprogs/Makefile
+++ b/tools/e2fsprogs/Makefile
@@ -8,8 +8,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=e2fsprogs
-PKG_VERSION:=1.42.13
-PKG_MD5SUM:=bc759fc62666786f5436e2075beb3265
+PKG_VERSION:=1.43.1
+PKG_MD5SUM:=1775f3f0eed9dee1c5f39e08d1964a97
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -23,6 +23,7 @@ HOST_CFLAGS += $(FPIC)
 
 HOST_CONFIGURE_ARGS += \
 	--disable-elf-shlibs \
+	--enable-libuuid \
 	--disable-tls \
 	--disable-nls
 
diff --git a/tools/e2fsprogs/patches/002-dont-build-e4defrag.patch b/tools/e2fsprogs/patches/002-dont-build-e4defrag.patch
index 9f6e7b1cef..2a7842f655 100644
--- a/tools/e2fsprogs/patches/002-dont-build-e4defrag.patch
+++ b/tools/e2fsprogs/patches/002-dont-build-e4defrag.patch
@@ -8,4 +8,4 @@
 +@DEFRAG_CMT@@LINUX_CMT@E4DEFRAG_PROG=
  @DEFRAG_CMT@@LINUX_CMT@E4DEFRAG_MAN= e4defrag.8
  
- @IMAGER_CMT@E2IMAGE_PROG= e2image
+ @LINUX_CMT@E4CRYPT_PROG = e4crypt
diff --git a/tools/e2fsprogs/patches/003-openbsd-compat.patch b/tools/e2fsprogs/patches/003-openbsd-compat.patch
index ded0ecad77..492b8a8860 100644
--- a/tools/e2fsprogs/patches/003-openbsd-compat.patch
+++ b/tools/e2fsprogs/patches/003-openbsd-compat.patch
@@ -1,6 +1,6 @@
 --- a/lib/blkid/getsize.c
 +++ b/lib/blkid/getsize.c
-@@ -25,6 +25,9 @@
+@@ -29,6 +29,9 @@
  #include <fcntl.h>
  #ifdef HAVE_SYS_IOCTL_H
  #include <sys/ioctl.h>
@@ -10,13 +10,3 @@
  #endif
  #ifdef HAVE_LINUX_FD_H
  #include <linux/fd.h>
---- a/lib/quota/mkquota.c
-+++ b/lib/quota/mkquota.c
-@@ -8,6 +8,7 @@
- #include <sys/stat.h>
- #include <unistd.h>
- #include <errno.h>
-+#include <stdint.h>
- #include <string.h>
- #include <fcntl.h>
- 
diff --git a/tools/e2fsprogs/patches/004-freebsd-compat.patch b/tools/e2fsprogs/patches/004-freebsd-compat.patch
index c6435d4919..d102e1cd9c 100644
--- a/tools/e2fsprogs/patches/004-freebsd-compat.patch
+++ b/tools/e2fsprogs/patches/004-freebsd-compat.patch
@@ -1,6 +1,6 @@
 --- a/lib/ext2fs/tdb.c
 +++ b/lib/ext2fs/tdb.c
-@@ -56,7 +56,9 @@
+@@ -58,7 +58,9 @@ Last Changed Date: 2007-06-22 13:36:10 -
  #include <utime.h>
  #endif
  #include <sys/stat.h>
diff --git a/tools/e2fsprogs/patches/005-darwin-compat.patch b/tools/e2fsprogs/patches/005-darwin-compat.patch
index c5d0e28c55..d84aa121ca 100644
--- a/tools/e2fsprogs/patches/005-darwin-compat.patch
+++ b/tools/e2fsprogs/patches/005-darwin-compat.patch
@@ -20,4 +20,3 @@
  #ifndef HAVE___U8
  #define HAVE___U8
  #ifdef __U8_TYPEDEF
-
-- 
cgit v1.2.3