From 5bf4a5903b9706cc8da81f783075056c0ff81c2e Mon Sep 17 00:00:00 2001
From: Gabor Juhos <juhosg@openwrt.org>
Date: Sun, 11 Apr 2010 17:47:28 +0000
Subject: ramips: generate sysupgrade images for the rt305x devices

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20801 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 target/linux/ramips/image/Makefile | 85 +++++++++++++++++++++++++++++++++-----
 1 file changed, 75 insertions(+), 10 deletions(-)

(limited to 'target/linux/ramips')

diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 363e9e2ecd..4cca2fcb34 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/image.mk
 IMGNAME:=$(BIN_DIR)/openwrt-$(BOARD)
 
 define imgname
-$(IMGNAME)-$(2)-$(patsubst jffs2-%,jffs2,$(1))
+$(IMGNAME)-$(2)-$(patsubst jffs2-%,jffs2,$(patsubst squashfs-%,squashfs,$(1)))
 endef
 
 VMLINUX:=$(IMGNAME)-vmlinux
@@ -30,26 +30,91 @@ define kernel_entry
 endef
 endif
 
+define CompressLzma
+  $(STAGING_DIR_HOST)/bin/lzma e $(1) -lc1 -lp2 -pb2 $(2)
+endef
+
+define PatchKernelLzma
+	cp $(KDIR)/vmlinux $(KDIR)/vmlinux-$(1)
+	$(STAGING_DIR_HOST)/bin/patch-cmdline $(KDIR)/vmlinux-$(1) '$(strip $(2))'
+	$(call CompressLzma,$(KDIR)/vmlinux-$(1),$(KDIR)/vmlinux-$(1).bin.lzma)
+endef
+
+define MkImage
+	mkimage -A mips -O linux -T kernel -C $(1) $(call kernel_entry)\
+		-n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+		-d $(2) $(3)
+endef
+
 define Image/BuildKernel
 	cp $(KDIR)/vmlinux.elf $(VMLINUX).elf
 	cp $(KDIR)/vmlinux $(VMLINUX).bin
-	$(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux -lc1 -lp2 -pb2 $(KDIR)/vmlinux.lzma
-	mkimage -A mips -O linux -T kernel -C lzma $(call kernel_entry) \
-		-n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
-		-d $(KDIR)/vmlinux.lzma $(KDIR)/uImage.lzma
+	$(call CompressLzma,$(KDIR)/vmlinux,$(KDIR)/vmlinux.bin.lzma)
+	$(call MkImage,lzma,$(KDIR)/vmlinux.bin.lzma,$(KDIR)/uImage.lzma)
 	cp $(KDIR)/uImage.lzma $(UIMAGE).bin
 endef
 
+define BuildFirmware/Generic
+	$(call PatchKernelLzma,$(2),$(3) $($(4)))
+	if [ `stat -c%s "$(KDIR)/vmlinux-$(2).bin.lzma"` -gt $(5) ]; then \
+		echo "Warning: $(KDIR)/vmlinux-$(2).bin.lzma is too big"; \
+	else if [ `stat -c%s $(KDIR)/root.$(1)` -gt $(6) ]; then \
+		echo "Warning: $(KDIR)/root.$(1) is too big"; \
+	else \
+		mkimage -A mips -O linux -T kernel -C lzma \
+			$(call kernel_entry) \
+			-n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+			-d $(KDIR)/vmlinux-$(2).bin.lzma $(KDIR)/vmlinux-$(2).uImage; \
+		( \
+			dd if=$(KDIR)/vmlinux-$(2).uImage bs=$(5) conv=sync; \
+			dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
+		) > $(call imgname,$(1),$(2))-sysupgrade.bin; \
+	fi; fi
+endef
+
+mtdlayout_4M=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),2944k(rootfs),3776k@0x50000(firmware)
+define Image/Build/Template/GENERIC_4M
+	$(call BuildFirmware/Generic,$(1),$(2),board=$(3),mtdlayout_4M,851968,3014656)
+endef
+
+mtdlayout_8M=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),7040k(rootfs),7872k@0x50000(firmware)
+define Image/Build/Template/GENERIC_8M
+	$(call BuildFirmware/Generic,$(1),$(2),board=$(3),mtdlayout_8M,851968,7208960)
+endef
+
+define Image/Build/Profile/DIR300B1
+	$(call Image/Build/Template/GENERIC_4M,$(1),dir-300-b1,DIR-300-revB)
+endef
+
+define Image/Build/Profile/FONERA20N
+	$(call Image/Build/Template/GENERIC_8M,$(1),fonera20n,FONERA20N)
+endef
+
+define Image/Build/Profile/V22RW2X2
+	$(call Image/Build/Template/GENERIC_4M,$(1),v22rw-2x2,V22RW-2X2)
+endef
+
+define Image/Build/Profile/WHRG300N
+	$(call Image/Build/Template/GENERIC_4M,$(1),whr-g300n,WHR-G300N)
+endef
+
+ifeq ($(CONFIG_RALINK_RT305X),y)
+define Image/Build/Profile/Default
+	$(call Image/Build/Profile/DIR300B1,$(1))
+	$(call Image/Build/Profile/FONERA20N,$(1))
+	$(call Image/Build/Profile/V22RW2X2,$(1))
+	$(call Image/Build/Profile/WHRG300N,$(1))
+endef
+endif
+
 define Image/Build/squashfs
 	$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
 endef
 
 define Image/Build
 	$(call Image/Build/$(1))
-	( \
-		dd if=$(KDIR)/uImage.lzma bs=1024k conv=sync; \
-		dd if=$(KDIR)/root.$(1) bs=65536 conv=sync; \
-	) > $(BIN_DIR)/openwrt-$(BOARD)-$(1).img
+	dd if=$(KDIR)/root.$(1) of=$(IMGNAME)-root.$(1) bs=128k conv=sync
+	$(call Image/Build/Profile/$(PROFILE),$(1))
 endef
 
 $(eval $(call BuildImage))
-- 
cgit v1.2.3