aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/patches-3.10
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/lantiq/patches-3.10')
-rw-r--r--target/linux/lantiq/patches-3.10/0103-tffs.patch12
-rw-r--r--target/linux/lantiq/patches-3.10/0104-nand.patch8
-rw-r--r--target/linux/lantiq/patches-3.10/0105-mips-lantiq-flash-add-jedec-probe.patch4
-rw-r--r--target/linux/lantiq/patches-3.10/0202-lantiq_ath5k.patch14
-rw-r--r--target/linux/lantiq/patches-3.10/0205-lantiq-nand-lock.patch4
-rw-r--r--target/linux/lantiq/patches-3.10/0206-lantiq-nand-lock.patch4
6 files changed, 19 insertions, 27 deletions
diff --git a/target/linux/lantiq/patches-3.10/0103-tffs.patch b/target/linux/lantiq/patches-3.10/0103-tffs.patch
index 04c2887ab7..3b0686d898 100644
--- a/target/linux/lantiq/patches-3.10/0103-tffs.patch
+++ b/target/linux/lantiq/patches-3.10/0103-tffs.patch
@@ -4,10 +4,8 @@ Date: Sun, 14 Jul 2013 22:26:43 +0200
Subject: add basic tffs driver
---
-Index: linux-3.10.13/arch/mips/lantiq/xway/Makefile
-===================================================================
---- linux-3.10.13.orig/arch/mips/lantiq/xway/Makefile 2013-09-29 00:18:30.164765435 +0200
-+++ linux-3.10.13/arch/mips/lantiq/xway/Makefile 2013-09-29 00:18:30.216765439 +0200
+--- a/arch/mips/lantiq/xway/Makefile
++++ b/arch/mips/lantiq/xway/Makefile
@@ -1,6 +1,6 @@
obj-y := prom.o sysctrl.o clk.o reset.o dma.o timer.o dcdc.o
@@ -16,10 +14,8 @@ Index: linux-3.10.13/arch/mips/lantiq/xway/Makefile
obj-$(CONFIG_PCI) += ath_eep.o rt_eep.o pci-ath-fixup.o
-Index: linux-3.10.13/arch/mips/lantiq/xway/tffs.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.10.13/arch/mips/lantiq/xway/tffs.c 2013-09-29 00:37:17.712792305 +0200
+--- /dev/null
++++ b/arch/mips/lantiq/xway/tffs.c
@@ -0,0 +1,87 @@
+#include <linux/module.h>
+#include <linux/mtd/mtd.h>
diff --git a/target/linux/lantiq/patches-3.10/0104-nand.patch b/target/linux/lantiq/patches-3.10/0104-nand.patch
index 2712e761f0..f4b5793284 100644
--- a/target/linux/lantiq/patches-3.10/0104-nand.patch
+++ b/target/linux/lantiq/patches-3.10/0104-nand.patch
@@ -1,8 +1,6 @@
-Index: linux-3.10.34/drivers/mtd/nand/xway_nand.c
-===================================================================
---- linux-3.10.34.orig/drivers/mtd/nand/xway_nand.c 2014-03-28 11:51:49.790953906 +0000
-+++ linux-3.10.34/drivers/mtd/nand/xway_nand.c 2014-03-28 15:45:08.196369790 +0000
-@@ -80,13 +80,16 @@
+--- a/drivers/mtd/nand/xway_nand.c
++++ b/drivers/mtd/nand/xway_nand.c
+@@ -80,13 +80,16 @@ static void xway_reset_chip(struct nand_
static void xway_select_chip(struct mtd_info *mtd, int chip)
{
diff --git a/target/linux/lantiq/patches-3.10/0105-mips-lantiq-flash-add-jedec-probe.patch b/target/linux/lantiq/patches-3.10/0105-mips-lantiq-flash-add-jedec-probe.patch
index 327a45ccd8..6ddb78bd53 100644
--- a/target/linux/lantiq/patches-3.10/0105-mips-lantiq-flash-add-jedec-probe.patch
+++ b/target/linux/lantiq/patches-3.10/0105-mips-lantiq-flash-add-jedec-probe.patch
@@ -9,8 +9,8 @@ Signed-off-by: Ben Mulvihill <ben.mulvihill@gmail.com>
lantiq-flash.c | 11 ++++++++++-
1 file changed, 10 insertions(+), 1 deletion(-)
---- a/drivers/mtd/maps/lantiq-flash.c 2014-03-23 09:18:25.099370216 +0100
-+++ b/drivers/mtd/maps/lantiq-flash.c 2014-03-19 17:19:45.732111306 +0100
+--- a/drivers/mtd/maps/lantiq-flash.c
++++ b/drivers/mtd/maps/lantiq-flash.c
@@ -117,6 +117,11 @@ ltq_mtd_probe(struct platform_device *pd
struct cfi_private *cfi;
int err;
diff --git a/target/linux/lantiq/patches-3.10/0202-lantiq_ath5k.patch b/target/linux/lantiq/patches-3.10/0202-lantiq_ath5k.patch
index cf95b8d46f..8ec9ff45cf 100644
--- a/target/linux/lantiq/patches-3.10/0202-lantiq_ath5k.patch
+++ b/target/linux/lantiq/patches-3.10/0202-lantiq_ath5k.patch
@@ -1,8 +1,6 @@
-Index: linux-3.10.34/arch/mips/lantiq/xway/ath_eep.c
-===================================================================
---- linux-3.10.34.orig/arch/mips/lantiq/xway/ath_eep.c 2014-04-03 13:25:03.128464891 +0100
-+++ linux-3.10.34/arch/mips/lantiq/xway/ath_eep.c 2014-04-03 13:35:30.432482868 +0100
-@@ -36,10 +36,11 @@
+--- a/arch/mips/lantiq/xway/ath_eep.c
++++ b/arch/mips/lantiq/xway/ath_eep.c
+@@ -36,10 +36,11 @@ static int ath9k_pci_plat_dev_init(struc
return 0;
}
@@ -15,7 +13,7 @@ Index: linux-3.10.34/arch/mips/lantiq/xway/ath_eep.c
u32 mac_inc = 0, pci_slot = 0;
int i;
struct mtd_info *the_mtd;
-@@ -112,6 +113,18 @@
+@@ -112,6 +113,18 @@ int __init of_ath9k_eeprom_probe(struct
if (!of_property_read_u32(np, "ath,pci-slot", &pci_slot)) {
ltq_pci_ath_fixup(pci_slot, ath9k_pdata.eeprom_data);
dev_info(&pdev->dev, "pci slot: %u\n", pci_slot);
@@ -34,7 +32,7 @@ Index: linux-3.10.34/arch/mips/lantiq/xway/ath_eep.c
}
dev_info(&pdev->dev, "loaded ath9k eeprom\n");
-@@ -132,20 +145,19 @@
+@@ -132,20 +145,19 @@ static struct platform_driver ath9k_eepr
},
};
@@ -58,7 +56,7 @@ Index: linux-3.10.34/arch/mips/lantiq/xway/ath_eep.c
return 0;
return platform_driver_probe(&ath9k_eeprom_driver, of_ath9k_eeprom_probe);
}
-@@ -247,4 +259,4 @@
+@@ -247,4 +259,4 @@ static int __init of_ath5k_eeprom_init(v
{
return platform_driver_probe(&ath5k_eeprom_driver, of_ath5k_eeprom_probe);
}
diff --git a/target/linux/lantiq/patches-3.10/0205-lantiq-nand-lock.patch b/target/linux/lantiq/patches-3.10/0205-lantiq-nand-lock.patch
index f82774d889..08d81fd292 100644
--- a/target/linux/lantiq/patches-3.10/0205-lantiq-nand-lock.patch
+++ b/target/linux/lantiq/patches-3.10/0205-lantiq-nand-lock.patch
@@ -22,8 +22,8 @@ Signed-off-by: Ben Mulvihill <ben.mulvihill@gmail.com>
---
---- a/drivers/mtd/nand/xway_nand.c 2014-04-01 20:14:53.072824371 +0200
-+++ b/drivers/mtd/nand/xway_nand.c 2014-04-01 21:24:52.798612391 +0200
+--- a/drivers/mtd/nand/xway_nand.c
++++ b/drivers/mtd/nand/xway_nand.c
@@ -102,7 +102,6 @@ static void xway_cmd_ctrl(struct mtd_inf
{
struct nand_chip *this = mtd->priv;
diff --git a/target/linux/lantiq/patches-3.10/0206-lantiq-nand-lock.patch b/target/linux/lantiq/patches-3.10/0206-lantiq-nand-lock.patch
index 6e332b4bf9..34d7235ec6 100644
--- a/target/linux/lantiq/patches-3.10/0206-lantiq-nand-lock.patch
+++ b/target/linux/lantiq/patches-3.10/0206-lantiq-nand-lock.patch
@@ -20,8 +20,8 @@ Signed-off-by: Ben Mulvihill <ben.mulvihill@gmail.com>
---
---- a/drivers/mtd/nand/xway_nand.c 2014-04-01 21:24:52.798612391 +0200
-+++ a/drivers/mtd/nand/xway_nand.c 2014-04-01 21:20:33.924585096 +0200
+--- a/drivers/mtd/nand/xway_nand.c
++++ b/drivers/mtd/nand/xway_nand.c
@@ -54,8 +54,27 @@
#define NAND_CON_CSMUX (1 << 1)
#define NAND_CON_NANDM 1