aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/patches/0132-XXX-Add-boot-support-for-u-boot.ipq-image.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ipq806x/patches/0132-XXX-Add-boot-support-for-u-boot.ipq-image.patch')
-rw-r--r--target/linux/ipq806x/patches/0132-XXX-Add-boot-support-for-u-boot.ipq-image.patch55
1 files changed, 55 insertions, 0 deletions
diff --git a/target/linux/ipq806x/patches/0132-XXX-Add-boot-support-for-u-boot.ipq-image.patch b/target/linux/ipq806x/patches/0132-XXX-Add-boot-support-for-u-boot.ipq-image.patch
new file mode 100644
index 0000000000..c94c75abe2
--- /dev/null
+++ b/target/linux/ipq806x/patches/0132-XXX-Add-boot-support-for-u-boot.ipq-image.patch
@@ -0,0 +1,55 @@
+From 776fff11c1bf57e564a386521e56c277287a568c Mon Sep 17 00:00:00 2001
+From: Kumar Gala <galak@codeaurora.org>
+Date: Thu, 8 May 2014 13:40:16 -0500
+Subject: [PATCH 132/182] XXX: Add boot support for u-boot.ipq image
+
+---
+ arch/arm/Makefile | 2 +-
+ arch/arm/boot/Makefile | 11 ++++++++++-
+ 2 files changed, 11 insertions(+), 2 deletions(-)
+
+diff --git a/arch/arm/Makefile b/arch/arm/Makefile
+index 51e5bed..e9fc731 100644
+--- a/arch/arm/Makefile
++++ b/arch/arm/Makefile
+@@ -297,7 +297,7 @@ archprepare:
+ # Convert bzImage to zImage
+ bzImage: zImage
+
+-BOOT_TARGETS = zImage Image xipImage bootpImage uImage
++BOOT_TARGETS = zImage Image xipImage bootpImage uImage uImage.ipq Image.gz
+ INSTALL_TARGETS = zinstall uinstall install
+
+ PHONY += bzImage $(BOOT_TARGETS) $(INSTALL_TARGETS)
+diff --git a/arch/arm/boot/Makefile b/arch/arm/boot/Makefile
+index ec2f806..3cbc83e 100644
+--- a/arch/arm/boot/Makefile
++++ b/arch/arm/boot/Makefile
+@@ -25,7 +25,7 @@ INITRD_PHYS := $(initrd_phys-y)
+
+ export ZRELADDR INITRD_PHYS PARAMS_PHYS
+
+-targets := Image zImage xipImage bootpImage uImage
++targets := Image zImage xipImage bootpImage uImage uImage.ipq Image.gz
+
+ ifeq ($(CONFIG_XIP_KERNEL),y)
+
+@@ -80,6 +80,15 @@ $(obj)/uImage: $(obj)/zImage FORCE
+ $(call if_changed,uimage)
+ @$(kecho) ' Image $@ is ready'
+
++$(obj)/uImage.ipq: $(obj)/Image.gz FORCE
++ @$(check_for_multiple_loadaddr)
++ $(call if_changed,uimage,gzip)
++ @$(kecho) ' Image $@ is ready'
++
++$(obj)/Image.gz: $(obj)/Image FORCE
++ $(call if_changed,gzip)
++ @$(kecho) ' Image $@ is ready'
++
+ $(obj)/bootp/bootp: $(obj)/zImage initrd FORCE
+ $(Q)$(MAKE) $(build)=$(obj)/bootp $@
+ @:
+--
+1.7.10.4
+