aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ipq806x/image')
-rw-r--r--target/linux/ipq806x/image/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index 58c4e1e872..ff8b2c7d9b 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -104,6 +104,17 @@ define Device/AP148-legacy
BOARD_NAME := ap148
endef
+define Device/D7800
+ $(call Device/DniImage)
+ DEVICE_DTS := qcom-ipq8064-d7800
+ KERNEL_SIZE := 2097152
+ NETGEAR_BOARD_ID := D7800
+ NETGEAR_HW_ID := 29764958+0+128+512+4x4+4x4
+ BLOCKSIZE := 128KiB
+ PAGESIZE := 2048
+ BOARD_NAME := d7800
+endef
+
define Device/DB149
$(call Device/FitImage)
DEVICE_DTS := qcom-ipq8064-db149
@@ -122,6 +133,6 @@ define Device/R7500
BOARD_NAME := r7500
endef
-TARGET_DEVICES += AP148 AP148-legacy DB149 R7500
+TARGET_DEVICES += AP148 AP148-legacy D7800 DB149 R7500
$(eval $(call BuildImage))