aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/imx23/patches/100-soc-audio-support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/imx23/patches/100-soc-audio-support.patch')
-rw-r--r--target/linux/imx23/patches/100-soc-audio-support.patch30
1 files changed, 2 insertions, 28 deletions
diff --git a/target/linux/imx23/patches/100-soc-audio-support.patch b/target/linux/imx23/patches/100-soc-audio-support.patch
index 33a1ea43ff..ef07f92c78 100644
--- a/target/linux/imx23/patches/100-soc-audio-support.patch
+++ b/target/linux/imx23/patches/100-soc-audio-support.patch
@@ -1,5 +1,3 @@
-diff --git a/sound/soc/codecs/Kconfig b/sound/soc/codecs/Kconfig
-index 2f45f00..8226a88 100644
--- a/sound/soc/codecs/Kconfig
+++ b/sound/soc/codecs/Kconfig
@@ -125,6 +125,7 @@ config SND_SOC_ALL_CODECS
@@ -20,8 +18,6 @@ index 2f45f00..8226a88 100644
# Amp
config SND_SOC_LM4857
tristate
-diff --git a/sound/soc/codecs/Makefile b/sound/soc/codecs/Makefile
-index b9e41c9..e3b6654 100644
--- a/sound/soc/codecs/Makefile
+++ b/sound/soc/codecs/Makefile
@@ -118,6 +118,7 @@ snd-soc-wm9705-objs := wm9705.o
@@ -32,7 +28,7 @@ index b9e41c9..e3b6654 100644
# Amp
snd-soc-max9877-objs := max9877.o
-@@ -242,6 +243,7 @@ obj-$(CONFIG_SND_SOC_WM9712) += snd-soc-wm9712.o
+@@ -242,6 +243,7 @@ obj-$(CONFIG_SND_SOC_WM9712) += snd-soc-
obj-$(CONFIG_SND_SOC_WM9713) += snd-soc-wm9713.o
obj-$(CONFIG_SND_SOC_WM_ADSP) += snd-soc-wm-adsp.o
obj-$(CONFIG_SND_SOC_WM_HUBS) += snd-soc-wm-hubs.o
@@ -40,9 +36,6 @@ index b9e41c9..e3b6654 100644
# Amp
obj-$(CONFIG_SND_SOC_MAX9877) += snd-soc-max9877.o
-diff --git a/sound/soc/codecs/mxs-builtin-codec.c b/sound/soc/codecs/mxs-builtin-codec.c
-new file mode 100644
-index 0000000..144b225
--- /dev/null
+++ b/sound/soc/codecs/mxs-builtin-codec.c
@@ -0,0 +1,1128 @@
@@ -1174,9 +1167,6 @@ index 0000000..144b225
+MODULE_DESCRIPTION("Freescale MXS ADC/DAC SoC Codec Driver");
+MODULE_AUTHOR("Michal Ulianko <michal.ulianko@gmail.com>");
+MODULE_LICENSE("GPL");
-diff --git a/sound/soc/codecs/mxs-builtin-codec.h b/sound/soc/codecs/mxs-builtin-codec.h
-new file mode 100644
-index 0000000..75dee0b
--- /dev/null
+++ b/sound/soc/codecs/mxs-builtin-codec.h
@@ -0,0 +1,825 @@
@@ -2005,8 +1995,6 @@ index 0000000..75dee0b
+#define BV_AUDIOIN_ADCVOL_SELECT__MIC 0x00
+
+#endif /* __MXS_ADC_CODEC_H */
-diff --git a/sound/soc/mxs/Kconfig b/sound/soc/mxs/Kconfig
-index 78d321c..9b8dd7d 100644
--- a/sound/soc/mxs/Kconfig
+++ b/sound/soc/mxs/Kconfig
@@ -18,3 +18,13 @@ config SND_SOC_MXS_SGTL5000
@@ -2023,11 +2011,9 @@ index 78d321c..9b8dd7d 100644
+ help
+ Say Y or M if you want to add support for codecs attached to
+ the MXS SAIF interface.
-diff --git a/sound/soc/mxs/Makefile b/sound/soc/mxs/Makefile
-index 565b5b5..cd0cf16 100644
--- a/sound/soc/mxs/Makefile
+++ b/sound/soc/mxs/Makefile
-@@ -8,3 +8,12 @@ obj-$(CONFIG_SND_MXS_SOC) += snd-soc-mxs.o snd-soc-mxs-pcm.o
+@@ -8,3 +8,12 @@ obj-$(CONFIG_SND_MXS_SOC) += snd-soc-mxs
snd-soc-mxs-sgtl5000-objs := mxs-sgtl5000.o
obj-$(CONFIG_SND_SOC_MXS_SGTL5000) += snd-soc-mxs-sgtl5000.o
@@ -2040,9 +2026,6 @@ index 565b5b5..cd0cf16 100644
+obj-$(CONFIG_SND_MXS_SOC_BUILTIN) += snd-soc-mxs-builtin-pcm.o
+obj-$(CONFIG_SND_MXS_SOC_BUILTIN) += snd-soc-mxs-builtin-dai.o
+obj-$(CONFIG_SND_MXS_SOC_BUILTIN) += snd-soc-mxs-builtin-audio.o
-diff --git a/sound/soc/mxs/mxs-builtin-audio.c b/sound/soc/mxs/mxs-builtin-audio.c
-new file mode 100644
-index 0000000..088863e
--- /dev/null
+++ b/sound/soc/mxs/mxs-builtin-audio.c
@@ -0,0 +1,120 @@
@@ -2166,9 +2149,6 @@ index 0000000..088863e
+MODULE_DESCRIPTION("Freescale MXS ADC/DAC SoC Machine Driver");
+MODULE_AUTHOR("Michal Ulianko <michal.ulianko@gmail.com>");
+MODULE_LICENSE("GPL");
-diff --git a/sound/soc/mxs/mxs-builtin-dai.c b/sound/soc/mxs/mxs-builtin-dai.c
-new file mode 100644
-index 0000000..d12bde7
--- /dev/null
+++ b/sound/soc/mxs/mxs-builtin-dai.c
@@ -0,0 +1,588 @@
@@ -2760,9 +2740,6 @@ index 0000000..d12bde7
+MODULE_DESCRIPTION("Freescale MXS ADC/DAC SoC Codec DAI Driver");
+MODULE_AUTHOR("Michal Ulianko <michal.ulianko@gmail.com>");
+MODULE_LICENSE("GPL");
-diff --git a/sound/soc/mxs/mxs-builtin-pcm.c b/sound/soc/mxs/mxs-builtin-pcm.c
-new file mode 100644
-index 0000000..9f155df
--- /dev/null
+++ b/sound/soc/mxs/mxs-builtin-pcm.c
@@ -0,0 +1,69 @@
@@ -2835,9 +2812,6 @@ index 0000000..9f155df
+EXPORT_SYMBOL_GPL(mxs_adc_pcm_platform_unregister);
+
+MODULE_LICENSE("GPL");
-diff --git a/sound/soc/mxs/mxs-builtin-pcm.h b/sound/soc/mxs/mxs-builtin-pcm.h
-new file mode 100644
-index 0000000..2fba109
--- /dev/null
+++ b/sound/soc/mxs/mxs-builtin-pcm.h
@@ -0,0 +1,25 @@